Using a Sandisk ? Maybe Don't.

We've developed a growing suspicion around here of Sandisk USBs.

 

I'm not saying none will ever work. But a lot of failures have come down to that.

 

We recognize that Sandisk USBs are incredibly common and that some of you may have no other devices. You are welcome to try still, but we encourage you to beg, borrow, or ...well don't steal... a different brand for your installation needs.

 

The Bad Behavior We've Seen:

Any number of issues may be caused by Sandisks.

 

  1. USB cannot be written to (halts writing at 0% or gives some other error)
  2. Machine won't boot even though USB installer creation goes well
  3. Machine won't install and fails with "error code 1" error
  4. Machine starts installation and then hangs forever
  5. During dualboot install, machine gives an error that UEFI requirements are not met
  6. EFI File may not be visible on the USB (for UEFI boot cases)

 

 

IF you experience similar issues but do NOT have a Sandisk - you should still try changing brands as a troubleshooting measure. Whatever is wrong with Sandisks could definitely be wrong with other brands or devices.

 

If you see any bad behavior on our Sandisk that isn't mentioned here, please post about it in the USB category!

 

 

-------------------------------------------EDIT--------------------------------------

 

In the comments below, user Bob Salsburg offers a method he found on Sandisk's website which might help you put a Sandisk into a more usable state! If you try it, please report back for us!

 

Bob Salsburg                                                      October 04, 2016 12:42

On the SanDisk website, I found reference to a formatting tool from HP. It worked where nothing else did. (HPUSBDisk.exe) Tool is linked on this SanDisk support page:

http://kb.sandisk.com/app/answers/detail/a_id/19258/related/1

Have more questions? Submit a request

15 Comments

  • Avatar
    Jeffrey Tull

    I had a 16GB SanDisk Ultra. The USB creation worked perfectly. When I booted to select an EFI file it couldn't be found, even though the USB drive was visible and an option for USB booting. A USB I picked up at a technology conference as a promo worked perfectly.

  • Avatar
    Forrest Smith

    Thanks for the info Jeffrey!

  • Avatar
    Artur Vilas Boas

    Sandisk and Emtec are giving me the same problem: my OS only works with the USB stick in (and I`m suspecting that the OS may be installed in the USB drive, because I`m experiencing lags and speed issues). This could be an USB problem? Should I try with a Kingston instead? Do you recommend some brand? Thanks

  • Avatar
    Forrest Smith

    Artur,
    That sounds like it might be more your computer-model than an issue with your USB. You can definitely try with a Kingston, but known that the issue you're describing could be a number of other things.

    I encourage you to closely describe your hardware and experience so far in a separate thread.

  • Avatar
    Courtney

    I have a sandisk usb and it works with manually installing for me. Well I do have to do a few extra steps first to be on the safe side though but this is how I always do my clean installs.

    I made a linux mint USB (only 2 GB so can't put cloudready on it lol but perfect for most linux iso's since well they are usually small in size.) and use the built program Disks and deleted any partions on my hard drive. (optional)

    Then booted up cloudready os with my usb drive and then used the installer in which it hangs, so I just let it sit for about 2-3 minutes cause even though it hangs it erases the hard drive and does at least set up the hard drive for cloudready to isntall on.

    Then after the waiting for a bout 2-3 minutes. I manually turn off my computer since well you hit the x button on the installer and it just sits there. So manually have to shut it off then reboot into cloudready os.

    Now then this part only works with efi or uefi boot. So bios needs to have uefi or efi boot options. This does not support legacy boot/bios everytime it just freezes up or checks for bad blocks.

    So after doing all the above choose either uefi or efi boot. Then open up the terminal by pressing ctrl+alt+f2 and then enter chronos for login and chrome for password then use cd /usr/sbin and then enter sudo chromeos-install --skip_src_removable --dst /dev/sda (replace sda with where ever you are installing cloudready os to or just leave it as sda if that's where you know your hard drive is.)

    Now doing all this works for me so if you have a sandisk usb and have uefi or efi boot options then try my method and see if it will work for you. If not then only thing to do is well get a new usb sadly.

    Anyway hope I at least helped someone using a sandisk. (dual booting never tried it so no idea. This only works with single booting)

    Edit: Also the reason why a Sandisk usb might not work and as far as I know and have read about is that it's because, well they where made/designed for some odd reason to be be read as a actual hard drive. Which in all honesty don't get why a bit pointless in my opinion. 

    Edited by Courtney
  • Avatar
    Darren Miller

    NOW I read that Sandisk may be a problem!

    Trying to use a Sandisk Cruzer Glide 16GB to turn an old, generic laptop (with only 1GB of RAM) into a Chromebook. It seemed like the creation of the boot disk was going fine, even got the green check mark at the end! However, even after ensuring that the USB drive was the 1st place to boot from in BIOS, the computer still booted to Windows.

    So I checked the flash drive. My computers will detect that a USB device has been plugged in but none of them recognize it. I can't see what, if anything, is stored on that USB device. For all intents and purposes it's just a very small paperweight now. Any thoughts on how to resurrect this flash drive?

    Guess I'll go get a different flash drive and start over from scratch....

  • Avatar
    Darren Miller

    OK, so I got an PNY flash drive and have exactly the same problem as I did with the Sandisk. Whereas my computer would allow me to view the contents of the flash drive before trying the boot disk creation procedure, now I cannot. I'm told I need to format it, and the only option I'm given is a 1.1GB format (on a 16 GB drive).

    Something is clearly wrong.

    Having read another thread on this forum, though, I may at least be able to recover the flash drives for use.  Still, I didn't need to spend $40 on flash drives only for this process not to work.  What a bummer.

    Edited by Darren Miller
  • Avatar
    Forrest Smith

    Derek -

    You can use the Chrome Recovery Utility to wipe and thereby recover fully those USBs - just select the gear icon > Erase Recovery Media

    As for getting your machine installed - Are you dualboot installing or standalone? Open a new thread, if you want, and give some hardware info and any other details you have and we can try some things.

  • Avatar
    UnknownVT

    There might be slight chance on this.

    Sandisk flash are very well known and popular -
    which unfortunately, also means there are lots of counterfeits/fakes out there.

    I ordered a 16GB Sandisk Ultra Fit CZ43 USB3.0 before I found this thread.
    It arrived today and I had prepared myself for problems -
    but it accepted and created an installation USB (cloudready-free-47.1.85.bin.zip) and booted fine on my target notebook (HP TouchSmart 11-e010nr, Windows 8.1)

    I chose this USB flash drive because it is very small (hardly protrudes when inserted) - fast (claimed up to 130MB/s read - I get 103MB/s on my old PC, USB3.0) - and I got it at a very good price ($6.33 shipped) - off eBay -

    BUT it was listed as (and received) in sealed retail package.

    The appearance, packaging and my tests confirm it is most likely genuine, despite the low price.

    Just a thought.

  • Avatar
    william bright

    8gb sandisk cruzer glide usb will work I installed chrome os with it

  • Avatar
    Peter Li

    UPDATE: I think the below is a red herring.  Probably the issue with installing to the VAIO was that cgpt was complaining when trying to install over a MBR disk.  Once I'd installed CloudReady once, the disk was GPT so the reinstall was smoother.

    Old comment:

    I agree it seems to be an issue with how sandisk tries to be a normal hard disk. I initially had to do my install on a Sony Vaio VPCCW13FX with a sandisk cruzer fit 8GB manually (chromeos-install with additional futzing). In the process I ran parted on the USB drive (which comes up as sdb since it's trying to be a hard disk) and let it fix the partitions:

    $ parted /dev/sdb
    (parted) print list

    Just "f" for fix all the things that come up.

    Subsequently, I reinstalled on the same machine, with the same sandisk, and the GUI worked; didn't have to do things manually anymore.

    Edited by Peter Li
  • Avatar
    Kristopher Rhen

    I was a victim of this too (hung at the three strobing "installing now" circles). Switched to a PNY and install worked.

  • Avatar
    Bob Salsburg

    Same issue with Lexar sporadically. I had used then for Linux installations for over a year.

    On the SanDisk website, I found reference to a formatting tool from HP. It worked where nothing else did. (HPUSBDisk.exe) Tool is linked on this SanDisk support page:

    http://kb.sandisk.com/app/answers/detail/a_id/19258/related/1

  • Avatar
    Random Internet Surfer AKA RIS

    Lexar seemed to work fine for me however I used Win32DiskImager since I got stuck at 0% during install with Google's Software.

  • Avatar
    unemployed man (pls give me a job pls)

    A solution IF your sandisk drive loads a "U3" partition by default: http://kb.sandisk.com/app/answers/detail/a_id/2550/~/removing%2Funinstalling-u3-launchpad-on-a-pc#method2

    Uninstall U3 using the above executable, then retry the Chromebook Recovery Utility to both "Erase recovery media" and "Use local image" to create a recovery media as written in the Neverware guide (https://guide.neverware.com/build-installer/working-windows/).

     

    Additional Notes

    1. Data point: Sandisk Cruzer 8GB with U3 additional partition does not work. Stuck at 0% in Chromebook Recovery Utility.

    2. Alternative URL for HP USB Utility (suspected aka MTX Utility) from HP, not CNET or Download.com: http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_948972949139480992fcb5b558

    3. Alternative formatting option using Command Line Prompt from Microsoft: https://technet.microsoft.com/en-us/library/jj200124(v=ws.11).aspx

    Edited by unemployed man (pls give me a job pls)
Please sign in to leave a comment.
Powered by Zendesk