Automatic update of CloudReady on virtualbox fails and bricks

Comments

8 comments

  • Joseph Honnoll

    Of course it'll brick/Fail to boot. CR Creates just too many partitions for VB to handle. Just turn Auto-Updates off LINK

  • Paul Beardsell

    I guess automatic update has worked before. I have no idea what my version of Cloudready my chomebook was on but it was several months installed and I seem to remember updates. So I'm unsure about your "of course".

    However, as a fresh install doesn't boot either this once again calls your "of course" into question.

    Please feel free to comment further but I think best to disregard your response and to reassert the bug.

  • Joseph Honnoll

    Just create a new VM with CR and be sure to Know the version by either the Login-Screen top-Left or by the About in Settins

  • Paul Beardsell

    I'm new around here but you already annoy with your know-it-all attitude. You will see that since my bug report the bug I report is acknowledged with a new paragraph top of this page: https://neverware.zendesk.com/hc/en-us/articles/214564457--UPDATED-Un-Official-CloudReady-Virtual-Machine-Images-

  • Joseph Honnoll

    Sorry I don't mean to be rude here sir. Just a guy who know his way through Linux somewhat. Didn't go to college so. Have a Learning Disabilitie so

  • Paul Beardsell

    Your several posts several topics appear to give solutions to the bugs reported but (in my case at least) do NOT. This is a support forum, not a chat forum. I cannot make allowances for that which I do not know, and whereas I acknowledge you may have difficulties, my own disabilities I do not disclose, and they may be more serious than yours. I merely attempt to report a bug. Please do not appear to resolve it when you do not as then others may disregard my bug report. Thank you.

  • Martin Bartos

    Despite of what is being suggested here, the real problem is somewhere else (definitely not "too many partitions").

     The latest "VM friendly" version would be v56.3.82.  Newer versions after that have replaced X11 for Freon.

    At this time; Freon does not seem to fully support virtual GPUs (and is having problems with physical nvidia/AMD as well).

     

    A solution to this would be to disable auto-updates:

    - Boot ChromiumOS (ideally with virtual network interface disconnected)

    - At the login screen; CTRL+ALT+F2

    - login with user chronos (default password would be chrome)

    #sudo su -

    #mount -o remount,rw /

    #mv /etc/init/update-engine.conf{,.disable}

    - To re-enable updates; you have to rename the update-engine.conf.disable script back to its original update-engine.conf

  • Ryan Zmuda

    Any new versions plans for a fix yet? 

Please sign in to leave a comment.