Cannot dualboot even with UEFI

Comments

8 comments

  • Forrest Smith

    Hey Kal,

     

    1) You probably want to remove your "Disk 1" for the duration of the CLoudReady install - our dualboot installation will only properly install on the same drive as UEFI Windows. It automatically borrows 32GB of space from your main Windows partition (Disk 0, C in this case) and the installs CloudReady there. Having Disk 1 in place could be causing problems.

     

    2) If removing Disk 1 temporarily doesn't so the trick, check out this link.

    0
    Comment actions Permalink
  • Kal

    Hi Forrest, 

    Thanks a lot for your reply. I detached the second hard drive altogether. That seems to have been an issue. Then I faced a problem with fast startup and thanks to your link, I was able to get past that as well. And the installation process seems to have been completed (The computer shutdown after installation).

    So now when I start the computer (2nd HDD still detached), I get two boot options: CloudReady and Windows. But when I select cloudready I get a blank screen with just 'Local Image A' written. However, if I plug-in the bootable USB and do a regular start up (not boot mode) I see the two boot options as well and I can use cloudready. So I checked the options and I still see the option to install cloudready, so I tried installing again. But the problem persists. 

     




    0
    Comment actions Permalink
  • Kal

    Also, I have a feeling this has got something to do with the partitions on my current disk.

    Here's how it looks like right now (I didn't do any of that):

    0
    Comment actions Permalink
  • Forrest Smith

    Hey Kal,

     

    Unfortunately I'm not sure what might be causing the boot to get hung on the "local image a" screen.

     

    Can you try, without the USB inserted, using the one-time boot menu to boot into CloudReady? It will probably be one of a couple entries under the "UEFI" menu (same one you posted a pic of before)

    0
    Comment actions Permalink
  • Kal

    Well, yes... That seems to have worked. Under uefi I selected clouready and it worked fine (without USB).
    So will I have to one-time boot Everytime I want to use it ?
    Is this an issue of the system not defaulting to uefi on startup ?

    0
    Comment actions Permalink
  • Forrest Smith

    I don't know what might be stopping the CloudReady dualboot OS-picker screen from properly selecting the OS, so I can't offer any particular way to resolve the issue. It might be that somehow UEFI-mode isn't being properly used when trying to boot CloudReady - if your BIOS has any setting to disable legacy-mode or alter any other boot-related tools you might want to fuss with those.

     

    You could also maybe use BIOS settings to set your default boot option to be CloudReady, rather than the OS-picker. If you mostly want to boot into CloudReady, but only sometimes need Windows, this would let you use the one-time boot menu only as often as you need Windows.

     

    Otherwise, yeah I think using the one-time boot menu anytime you need CloudReady is your best bet.

    0
    Comment actions Permalink
  • Kal

    I think I figured it out. In the boot setup, 'Enable Legacy ROMs' was selected. This enabled legacy ROMs oven in UEFI mode. Now that I've deselected it, everything works just fine!

    Thanks a lot for your help, Forrest. I was fed up with windows and have been wanting to make the switch to chrome os for a while now. I decided to try cloudready after I heard about google's funding. I think it is a great project for you guys and I wish you all the very best in your endeavors!

    Thanks again,

    Kal

    1
    Comment actions Permalink
  • Forrest Smith

    Glad it's working!

    Enjoy.

    0
    Comment actions Permalink

Please sign in to leave a comment.