Works on Acer C710-2847 (parrot) Chromebook

Comments

23 comments

  • Forrest Smith

    Hey Dennis -

    LOVING the use of actual Google hardware here.

    I'm surprised it didn't sync all your apps and extensions - were some missing, or all missing? We don't package in the Chromebook default apps (Docs, Sheets, etc) but everything else on your profile should sync.

    If you get crouton working that would be exciting (we're definitely using a pretty vanilla Linux kernel, so it should be possible). Keep us updated!

  • DennisLfromGA

    Forrest,

    Just some of the apps and extensions were missing, like Secure Shell, Crosh Window, goo.gl URL shortener and a few others. I didn't realize that Docs, Sheets, etc. weren't packaged so that explains that. ;)

    I've got a 'crouton' chroot installed but am having trouble getting any gui desktops working. I've left feedback on the crouton github site (https://goo.gl/emTMBp) about it so hopefully we'll get that working soon.

  • Geo Murch Jr.

    That's really nice :) 

    I'd like to install Cloudready on my Acer C7 Chromebooks :)

    They are nearing no more updates from Google so Cloudready would be an option :)

    George

  • Peter Michael Beck

    Did anyone actually find a way to install cloudready on an old Acer C7 Chromebook?   Mine is at end of life and I would much appreciate a lesson on how to do this if it is actually possible.    It seems like a shame to junk such a nice machine just because google decided not to support it anymore!

     

  • Chris Horry

    It works, but every time I do an update it freezes at the CloudReady logo and I have to reimage.  Tried beta, dev and stable updates and always the same result.  Reimaging fixes it until the next update.

  • Chris Horry

    Updates are working now as of 72.4.35, not sure what changed but this is the first time I've been able to run an update without a reimage.

  • Peter Michael Beck

    Hi Chris. - You are way ahead on this. I still love my C7 710 but am stuck at version 65! I am not “technical” but tried going to dev mode and install cloudready 4 times now failing every time! Do you know of anyone who could do the install for me if I shipped my little C7 to them? Peter

  • Chris Horry

    It should be as simple as using the CloudReady USB creator utility then inserting your USB key into the Chromebook.

    1. Use the CloudReady USB Creator to create the image (takes about 30 minutes)

    2. Power on your Chromebook, as soon as you see the warning about being in developer mode hit Ctrl-U

    3. Once it's done booting off the USB key (eg the CloudReady welcome screen appears) click on the Clock then "Install OS". 

    4. After about 10 minutes the Chromebook shuts down.  Remove the USB key.  Power it on and WAIT, you'll get the warning screen, then it'll beep after about a minute, then after a few more seconds it'll boot up and you're ready to go.

    Let me know if you need anything clarified, I'll be happy to help.

  • DennisLfromGA

    Hey Chris,

    I just installed the latest free version using that same method:

        Chromium 72.0.3626.83 (Official Build) (64-bit)
        Revision 0
        Platform 72.4.35 (Developer Build - neverware) developer-build chromeover64
        Firmware Version Google_Parrot.2685.37.0

    Problem is, although the device is in Developer mode I cannot get to VT-2,3, etc. nor a bash shell session with 'ctrl+alt+t' and entering 'shell' at the 'crosh >' prompt, see below -

    I'd be very curious to know if you or anyone else is able to access a shell session using this free version.

    Also, I'd be interested in knowing if any Chromebooks can install cloudready without being in Developer mode.

    Regards,
    ~Denny

  • Peter Michael Beck

    Chris,

        Tried again.   I boot to the Dev mode warning.   Try the control-U and I get "The thumb drive does not contain a recovery" or something like that?   Am I missing a step?

        Peter

  • Chris Horry

    As I understand it, you can only get to a proper Linux shell with the paid editions but perhaps someone from Neverware can confirm that.

    Peter it sounds like you are not creating the USB key correctly. Follow the instructions here: https://guide.neverware.com/build-installer/automatic-usb-maker/

    You can also download the raw image at the bottom of the page here: https://www.neverware.com/freedownload and then just use the Chromebook Recovery tool from Google. 

    Both methods work well for me.  Only other thing I can think of is your USB key is somehow not compatible, but I've done it with numerous keys and never had an issue.

  • DennisLfromGA

    Chris,

    That may indeed be the answer to the missing shell session but I'll try to follow up with Neverware support to be sure, If I get an answer I'll post it back here too.

    I am using Crostini / Linux (Beta) so not all is lost, I can probably live with that for now at least.

    Thanx.

     

    Peter,

    I downloaded the 64-bit free image from the page that Chris linked above and then used the Chromebook Recover Utility that Chris also mentioned to write the image. Complete instructions for that method for Chromebook users is here (link).

    Regards,
    ~Denny

  • Forrest Smith

    Dennis/Chris -

    Actually the paid Editions don't allow any shell access, ever. That security is part of what our customer pay for.


    The Home Edition typically does allow shell access, but on an official Chromebook there's some funkiness.

    We support security features on CloudReady that Chrome OS only uses when booting in verified mode - roofs verification, secure boot. I think one or both of those features confuse your Chromebooks when running CloudReady, because at a firmware level they are set to dev mode (to allow booting an external OS) but the disk tells them that non-dev mode security features are present. 

    Ultimately I suspect that is the reason you can't access the shell. The only workaround I can think of is:

    1) Install on some other PC or Mac

    2) disable verity from cmd line

    3) transfer that PC or Mac's storage to your Chromebook (physically move the device) or make a direct bitwise copy (using Linux dd utility or similar) to copy the PC/Mac storage over to the Chromebook internal storage.

     

    All of the above will likely require you remove the internal storage on your Chromebook in some way, and have equipment to interact with it via a USB adapter or something. I can't offer more specific instructions since I've never done it, and I am not confident it'd work - just that you could try. 

  • Peter Michael Beck

    All of the above makes me feel that making my end of life Acer c-710 into a cloudready device is possilbe and at the same time frustrates me in terms of my low Technology IQ.     Is there anyone out there who can do this conversion for me if I send my computer and pay the postage both ways.   Even willing to pay for your time - I know it will take me till the end of time to figure out what I am doing wrong.   

    Let me know if anyone is interested and I will send you my contact info.

     

    Thanks

  • DennisLfromGA

    Forrest,


    Thanx very much for the thorough explanation and possible workaround.

    I had read that the free Home Edition did include Developer mode-like shell access but I couldn't get it to work on a Chromebook. I do indeed have a developer build:

         72.4.35 (Developer Build - neverware) developer-build chromeover64

    So now I understand the funkiness I'm running into at least. :-)

    For me, the extra steps to access a shell session just aren't worth it, especially since this version supports Linux (Beta) which I have working just fine now. I use crouton chroots on my other Chromebooks but it's not that necessary to have it on my slow & old Acer C7. :-)

    Thanx for taking the time to explain this to us, I've been struggling with it for a while, this topic is 3 years old. ;-)

    ~Denny

  • Chris Horry

    Peter, I would hate for you to pay to do this and would feel guilty even taking payment, but if you live in Central FL perhaps I can come over and help you out? :)  Try with a different USB key and let me know what the results are. 

  • Peter Michael Beck

    Hi Chris,

         I live in the Washington DC area - funny my wife and I were in Orlando (Disney World) last week for the first time in many years - now we are back in the snow!   Maybe I can ship my C-710 down to you by post?  My e-mail is beckpm@me.com
    E-mail me your phone and I will give you a call.   By the way, I have tried it with several thumb drives - I have installed CloudReady on three old PCs with no problem, just can't seem to do it on my old Chromebook that has reached end-of-life.

          Thanks,

              Peter

  • Chris Horry

    Did you ever get this working?

  • DennisLfromGA

    Not sure if Peter got this working or not but I have a colleague with the AcerC710 that needed some guidance so I wrote up a little how-to that helped him, it may help others too - it's linked below -

    ~Denny

  • Chris Horry

    Thanks for that Denny, Peter if you're still out there and really stuck you can mail it to me.  I can't guarantee I'll get it working but I'll give it a shot for you.  I've been very busy at work lately so haven't had much time to check on these forums.

  • Jay Strumwasser

    @forrest smith, I was told by Carell Hamil that this is not supported.  Can you give me more information about this?  I have 340 devices going EOL and looking to reimage them with cloudready

  • Forrest Smith

    Jay,


    Other users may be able to assist you, but since this is unsupported (and we don't have a C710 here in our QA lab to work with anyway) I can't really advise personally.

    If you find guides on the web for installing other OSs (maybe Linux of some other kind) onto this device, you may be able to follow those and then install CloudReady that way. 

  • David Sokolowsky

    I just upgraded two Acer C710 to CloudReady.  These are also very easy to upgrade RAM and HDD/SSD, if you like.  

    I followed a few pages since they are a bit dated. But, basic steps:

    - disable BIOS write-protect (small jumper on motherboard - very easy to get to)

    - flash BIOS using ChromeOS Firmware Utility Script at mrchromebox.tech

    - now can boot from USB and install CR or other of choice.

    I can provide more info if wanted.

    I found one issue so far, which is not being able to cast video to a Roku or other similar TV device.  But, all else seems to work well.

Please sign in to leave a comment.