I think I figured out how to make auto-update work for a USB install...

Comments

12 comments

  • Duong Pham

    Please update if it worked :) it'd be great if we can run cloudready full fledged with only an USB.

  • Dennis Grudzinsky

    Where can I download the previous version of Cloudready to test updating? I've since wiped that USB drive since I needed it for something else.. 

  • Dennis Grudzinsky

    OK, I found an old download of v44 on one of my external hard drives. I flashed it to my flashdrive and went through this procedure, then attempted to update. It worked perfectly and updated to v45 without any problems. Would be great if it worked this way by default in the next release :)

  • Duong Pham

    That's great! Would you mind explain what you did step-by-step? The original post is kind of hard to understand. Thank you so much! :)

  • Dennis Grudzinsky
    1. Flash Cloudready to USB drive
    2. Boot Linux, start gparted
    3. Delete the small ROOT-B partition on the USB drive
    4. Move all the partitions after it all the way to the right
    5. Copy the ROOT-A partition, and paste it into the unallocated space after the ROOT-A partition.
    6. Rename the copied ROOT-A partition to ROOT-B
    7. Move the partitions from step 4 back to the left
    8. Expand the STATE partition to fill the remaining space on the drive

    Since Chromium OS uses a blue-green deployment method for updates, it needs two identical ROOT partitions to update properly. In the default USB drive image, the ROOT-B partition is only 16MB and isn't formatted, so it is basically a dummy partition. I simply replace it with a copy of the ROOT-A partition and that makes it identical to a real hard drive install. 

  • Duong Pham

    Thank you so much Dennis! :D

  • Kusher

    Work fine, thx :)

  • Kai Bolay

    Thanks for the instructions. I couldn't find any ROOT-B partition, so I just copied ROOT-A and renamed it. I didn't bother moving and resizing STATE. Is that required? Because in my current setup I still see "Install Cloudready"...

  • Dennis Grudzinsky

    I think they changed something in the latest version. Back when I did this (version 44, I think) there was a "dummy" unformatted 16MB ROOT-B partition already on the drive, directly after ROOT-A. Looks like in the latest release there is a change in the software that removes the need for the extra partition on the USB, as I can't get the same thing to work with the latest version. 

    If you still have a download of 44 around, try flashing that, perform the procedure on there (make sure to delete the dummy ROOT-B, then put the real ROOT-B in the same spot; this will involve moving partitions around), and then upgrade via the auto-update. If you do this correctly, the Install Cloudready option should disappear. 

  • Kai Bolay

    Unfortunately I didn't download any version before 45. If anyone has a download link for 44 I'd be grateful for sharing it.

  • Dennis Grudzinsky

    Here you go: https://drive.google.com/open?id=0B9Nu9cY0UBvqVUV5aHQ3WTVHV0k

    Just extract the 7z file. I had to re-compress it since I lost the original zip file, and 7z is smaller anyways. 

  • Phil Reilly

    This doesn't work for live updates

Please sign in to leave a comment.