Installation Problem

Comments

28 comments

  • Hdgsoftball

    Ok...I've tried 2 different working HP6730b laptops. Both have good drives and booted to Windows 7 just fine. They are old beaters so I thought I'd try the newly released free CloudReady. Sad to report that both are now bricked after trying the installation. Followed the directions step by step with no success. Reset Bios to factory defaults, made a second usb bin installer using the recommended Chromebook Restore utility only to get the same result. My above posts describes what's happening. If anyone has successfully installed the free version that was released yesterday ( Oct 1 ) I'd love to know the secret to making it work.

  • Sara Caldwell

    Usually, non-system disk errors are addressed by resetting the BIOS to defaults and trying a reinstall. That is a good first step.

    For the HP6730b, if you are using a USB 3.0, we'd recommend switching to a 2.0.

    For the HP4430s, it appears our documentation was not complete on the Features and Exceptions page -- the model requires UEFI enabled to boot. We've updated it now, and listed the installation instructions for that model below.

    "To install on this machine, enable UEFI in the BIOS prior to installation. When installing, choose your boot device as: "Boot From EFI File" > locate your USB > "efi" > "boot" > "bootx64.efi""

    Let us know what you find!

  • Hdgsoftball

    I'll try and report back. I was using a usb 3.0 drive with both models. I'll create a new one on a 2.0 to see if it makes a difference.

  • Hdgsoftball

    Okay...here's the latest on the HP6730b. After creating another install 2.0 usb we get the same result. I can log in and run the usb live no problem. Everything seems to work great. I log out as instructed then try to install and it does what my original posts says. It gets to the install screen, sits for 10 minutes or so, powers off and on restart I get "Non-system disk error replace and strike any key when ready".

    Bios has be reset to all factory defaults. This has been tried on two separate HP6730b laptops. Either something is off with what I'm doing or the installer I downloaded this morning is defective.

    Any ideas from her???

  • Forrest Smith

    Hi There!

    On your most recent USB boot, right before installing, did you choose "Boot From EFI File" > locate your USB > "efi" > "boot" > "bootx64.efi" like Sara suggested?

    If so - go into your BIOS now and enable UEFI boot. Then start up again - that may do it for you.

    If that doesn't work let us know. If you didn't follow Sara's bootup sequence, try that.

    In general think of it this way: if you USB-boot (and then install) form a UEFI/EFI file, then your computer needs to be in UEFI mode after that. If you legacy boot and install, then your computer needs to stay in legacy mode. Some machines need to be in UEFI, some need legacy, some can do both, but the install method needs to match the boot mode.

    I know that's sort of confusing, but hopefully that helps!

  • Hdgsoftball

    Hello...On the 6730b in the Bios or during boot I don't see anything resembling what you are talking about. They don't have efi or boot from efi etc....

    She was talking about the 4430 in her answer. I gave on that one because it turns out the battery needs replaced. Not willing to spend any money on it at this point. The 2 HP 6730b I have are in really good shape. They are the ones I'd like to get running.

    Any other suggestions or am I missing something with the Bios and EFI ect...?? I looked through it twice and they do not appear to have those features / options. Thanks

  • Hdgsoftball

    Just found the settings in the bios for the 6730b...stand by while I try again. I'll post results later. Ty

  • Michael Pobega

    Have you had any luck getting it to work with the proper UEFI settings? I'd love to mark this solved with a solution so others can find their solution in this thread!

  • Hdgsoftball

    I was able to install and boot from the internal hard drive but every time I start the laptop I need to go through the sequence of "Boot From EFI File" > select the internal hard drive > "efi" > "boot" > "bootx64.efi" just like I did when booting from the USB.

    Is this the norm??

  • Forrest Smith

    Hi there - this sounds like progress.

    It is not desired or typical behavior to need to select bootx64.efi" *every time you boot.

    However, it sounds like you're potentially only one step away. Can you update the BIOS to manufacturer's latest? That may help.

  • Todd Moore

    I am having the exact same issue with HP 6735b's. Even after enabling UEFI, booting into the USB drive's EFI file and installing that way, I still get the non-system disk error on reboot. I am evaluating Cloudready for our school to see if it is a viable option to re-purpose our laptops at their end of life cycle but will have to get this working to justify cost vs. just buying new Chromebooks.

  • Forrest Smith

    Todd,

     

    I actually have a suggestion specifc to HP 6735b machines:

     

    I have a note that installing (in Legacy boot-mode, with UEFI off) on a 6735b works fine if you use a USB 2.0 stick. Using USB 3.0 you can install in UEFI mode, but it causes the problem you describe where the EFI file must be chosen repeatedly.

     

    Let me know if a Legacy-boot works when you use a USB 2.0 stick.

  • Nightwish

    Hi, i am reading here now a few days. I tried a standalone install on my old and slow, but still okay as a spare laptop, HP compaq 6730b.

    At the end of installation i had  the same problem as mentioned in this thread. It runs for a while and shuts off. On reboot there was the non sytem disk error. I tried different settings, installed and downloaded again and again... bought a 2.0 usb-stick and tried again. Yeah it worked leaving the stick in, as soon as i took it out it didn't work anymore.

    Because i spend so much time on reading and trying, last night i gave it another go. It says maybe bios upgrade will help so that was my last option. I installed win 7 back on it, updated the bios to version F20 and made new files again.

    It took me all night (bios update wouldn't work) but finally it's all done. CloudReady install went okay, it boots fine, so i think it looks all okay now!

    Hopefully it stays like this, i played a few hours with it (but i need a bit sleep now :D) I'm really surprised how nice and fast it all works. I thought this thread can do with some good news and maybe it helps other people!

     

  • Tom Miller

    The bios update fix strikes again :)

  • Forrest Smith

    Thanks for solving the mystery Nightwish!

  • Nightwish

    Thanks for the free CloudReady and this community!

    This afternoon i made a family member (her age near 70) very happy with the laptop. Finally something she can understand because it is not too complicated and she just has to remember a few things.

  • Conor Davies

    Like Todd More I am trying to re-purpose HP 6735b and like Todd I can run the installer from USB, machine appears to install for 5-10 minutes then shuts down, as expected.

    Upon restart I also get "Non-system disk error replace and strike any key when ready" error.

    I am using USB 2 stick and UEFI mode is DISABLED in System Configuration.

    Laptop had UBUNTU previously but imagine that now deleted during attempt at CLoudReady install process - so unsure how to proceed with investigating BIOS upgrade or next steps.

    Any further suggestions or solutions appreciated.

    Thanks in advance

  • Forrest Smith

    Conor - 

     

    I wouldn't delay the BIOS update - our internal machine misbehaved until we updated to F.16 or higher.

  • Conor Davies

    That may be so, but I am unable to update BIOS at all.

    HP Bios update fails to create USB - some error about HPQFlash needingan earlier version, WMI not being suitable blah, blah, blah.

    I've spent the last 4 hours googling solutions to this and various other issues - each requiring another fix before moving on!

    I've prepared 4 USB sticks in various confirgurations, I've tried creating HP Utility and Diagnostics USB sticks, only to see them run perfectly well except for the fact that the 'Firmware Upgrade' option is missing from their  menu!

    I've tries Windows+B on boot-up to 'force' BIOS update utility, no response from computer. I tried Fn+B to do same. I tried holding all 4 arrow keys together to force BIOS update.

    Nothing works.

    Stuck on BIOS f.11 and cannot find a way to upgrade it.

  • Forrest Smith

    Conor - 

     

    You should try placing the BIOS update file on the same usb that you've made into a HP Utility and Diagnostics stick.

     

    If an applicable file it present the option to "update BIOS" may be selectable.

  • Conor Davies

    I've now made the HP PC Hardware Diagnostics UEFI (version 6.0.2.0) USB. I tried the 3-in-1 diagnostics kit from HP but the download always fails right at the end.

    I#ve also downloaded various .exe BIOS update files from HP - all of which give me a 'no WMI, use HPQFlash version less than 4' error when I try to make a USB BOS updater out of them.

    Can you tell me which is the BIOS file that I should be looking for and where it should go on my Diagnostics stick, please?

    I have tried putting 68GTT.bin in the HPTools>BIOS>New folder bt I still don't get a 'Firmware update' or 'Update BIOS' option when I boot from the Diagnostics USB.

    Even the screenshot on the HP site shows a 'Firmare update' option on the main menu selection (http://www8.hp.com/us/en/campaigns/hpsupportassistant/pc-diags.html?jumpid=va_r602_us/en/any/pps/pl_ot_ob_ds_pd/HP_PC_Hardware_Diagnostics_cc/dt) - but my menu has that option missing entirely.

    Can't believe that this is such a difficult proces.

    Any further guidance gratefully accepted.

    Thanks in advance.

    Conor

  • Forrest Smith

    I think that was my last reasonable guess. Maybe head to the HP help forums and just explain that you don't have Windows install media, but need to update BIOS. Maybe they can help.?

  • Conor Davies

    Just experimented with FreeDOS version of F.16 BIOS - seems to be working!

    Maybe I can copy the Rom.bin file from the F.20 version to the FreeDOS USB stick and upgrade from F.16 to F.20?

    Would I need to rename the Rom.bin file to 68GTT.bin to make it recognisable?

    Let's see what happens!

    Thanks for suggestions so far.

  • Conor Davies

    BINGO!

    The FreeDOS BIOS update to F.16 worked and now CloudReady is running.

    Only 13 hours for my first install!

     

  • Forrest Smith

    Conor - 

     

    That is terrific - even if slow. Hope you enjoy! Best of luck on any future devices.

  • Martin Sarkar

     

    New thread posted for this issue.,

  • Forrest Smith

    Martin - 

     

    First - when new things like this come up, it's better to open a new thread so that folks can more easily search for the specific content of any given discussion.

     

    in this case - the 6730b should be on our certified models list where you can look for specific install details linked to it.

     

    For the 8530p, I'd recommend you compare to certified models in the same line of computer and of similar age (for instance, maybe the Elitebook 2530p or similar)

Please sign in to leave a comment.