Installation failed error

Answered

Comments

9 comments

  • Official comment
    Jaymes Driver

    Manual Installation of OS
    Follow the instructions Casey has listed for writing the image to your USB drive -> https://neverware.zendesk.com/hc/communities/public/questions/205453018-100-failure-rate
    or use the spiceworks article here -> https://community.spiceworks.com/topic/1215090-getting-ready-to-be-cloudready-3-tips-to-save-your-sanity?page=1#entry-5084153
    After burning the image to your USB flash drive with Win32 Disk Imager, start up the computer and boot to the flash drive.
    When the first screen comes up and asks you to select your network, press Ctrl + Alt + F2. You will find yourself at a command line.
    the username is: chronos
    the password is: chrome
    To install, type the following commands:
    cd /usr/sbin
    sudo ./chromeos-install --dst /dev/sda
    (where /dev/sda is your internal hard drive)
    Type the password listed above (chrome)
    Please verify the installation location. My computer says:
    "This will install from '/dev/sdb' to '/dev/sda'.
    This will erase all data at this destination: /dev/sda
    Are you sure (y/N)?"
    Type Y and press enter.
    Now you wait. You may see some errors like the following:
    "WARNING: Secondary GPT header is invalid"
    "WARNING: One of the GPT headers/entries is invalid"
    As far as I can tell, they can be ignored. Maybe someone can shed some light on the error and the cause. Maybe even a prevention/fix.
    The process will take 5-10 minutes.
    When the message "Please shutdown, remove the USB device, cross your fingers, and reboot." appears, Press CTRL + ALT + F1 to get back to the Welcome screen. Click Shutdown, remove your USB stick, and reboot.
    (or you can type "sudo shutdown -h now" and press enter)
    Marvel in your awesome, you are now CloudReady!
    Hope this helps. I am not sure WHY the installation fails, or where it fails when using the GUI, but thankfully, there is a CLI to fall back on!

  • El Amigo David

    Try installing again without log in. Using the option "Install Cloud Ready"

  • Forrest Smith

    Eduardo,

    Sounds like you did everything right. As David said already, if you didn't before, log out before initiating any kind of install. Also, make sure there's no other removable media in your computer besides the USB installer and the HDD or SSD you want to install to.

    Last of all, rebooting and retrying is always a good possibility.

    Report back when you have new results!

  • eduardo

    Nope, still getting error. I did log out and tried and rebooted, I'm wondering if it has to do with the laptop running Ubuntu OS?

  • Forrest Smith

    Eduardo,

    Is Ubuntu just what is previously installed? Or do you have the two OSs running simultaneously through some method (crouton, etc)?

    Anything which keeps the install-destination device mounted and/or being otherwise used when you initiate install could cause installation to fail.

  • eduardo

    Ubuntu is installed but I'm just trying to wipe it, I boot to USB and then try and install. Might need to remove os

  • Eric Baum

    The final answer method by Jaymes Driver worked for me.
    Although I did get an error "Error: Source does not look like a removable device: /dev/sdb".
    I had to use "sudo ./chromeos-install --skip src removable --dst /dev/sda" instead.

    Thanks Jaymes !!

    Note: There is supposed to be an underscore character before and after src in the above command. Not sure why it will not display...anybody?

  • Eric Baum

    One other note. After getting the "installation failed" my HDD was unrecognizable using command: sudo fdisk -l
    I actually had to re-partition and re-format the drive. Then it was recognizable and I was able to proceed with the steps outlined in this issue.

  • Jeff Bowman

    I had to turn off the check to see if the source was removable when I followed these instructions. (sudo ./chromeos-install --help to see options)

     

Please sign in to leave a comment.