Root/Administrator password



  • Official comment
    Forrest Smith

    Hi Lucas,

    You can get full root access. The easiest way is:

    1) "Ctrl+Alt+F2' to get to CLI
    2) log in with u: 'chronos' / p: 'chrome'
    3) get root with 'sudo su' (you'll need to use p: 'chrome' again

    From there, the world is your oyster.

  • Turbolego

    Hi Forrest,

    I followed your instructions, but i still get permission denied?

    I have not changed the user or password and "chrome" is accepted as password when i use sudo su.

    Any idea what might be wrong?


    "sh: /home/chronos/user/Downloads/crouton: Permission Denied"


    EDIT: I figured it out, i had to cd into the downloads folder from localhost and then use "sh crouton". It works now. Thx! :]

  • James T. Taylor III

    Hello all. I know that this has been answered and answered and answered.

    However I cannot log in using chronos and chrome as the u and p.

    I have also tried 'chronos' (including quote) and 'chrome' and still nothing.

    Build information is below.

  • Forrest Smith

    Hi ,


    1) That screenshot is not showing the relevant info - we need to see the version number which is on the page before. Here's mine:

    2) It sounds like you're trying to access this from a tty (accessed by pressing ctl+alt+f2) . Instead, do this:


    1) Log in

    2) Press ctl+alt+t to open a terminal

    3) Type in "shell" and hit enter

    4) Confirm that the yellow "crosh" prompt is now a green "chronos@localhost" prompt


    Does that work? Please send a screencap of the result if it doesn't.


  • James T. Taylor III

    No this did not work.  I do see the crosh is yellow then chronos@localhost is green.

    However the root password does not work.

    Here is a screen capture of version:

    here is the other screenshot you requested:

    That is me using chrome as password.

  • Forrest Smith

    Can you create a fresh live-bootable USB using the tools here and check if this behavior persists there?


    I would expect you to have no password required for this command. On earlier versions of CloudReady the password for user chronos was "chrome" but we removed the password altogether recently to encourage users to either set their own password or recognize that there is some insecurity. Maybe you just need a reinstall?

  • James T. Taylor III

    Fresh reinstallation and still requiring a password for command "sudo" inside of shell from the terminal using ctrl + alt + t.

    Additionally, I was able to get it working by going into the developer edition of cloudready.  Maybe it is because I just have the home edition using the stable release?

  • Forrest Smith

    What if you just leave the password prompt blank and hit enter?

  • Jack

    I'm on the latest beta channel, and this worked for me, give it a shot:

    1. Open terminal using 'ctrl + alt + t'

    2. Enter shell using 'shell' command

    3. Become root using 'sudo su' command

    4. Set the password using 'chromeos-setdevpasswd' command

    5. Set your new password

    6. Profit!

Please sign in to leave a comment.