Dell Inspiron 1470 ,Install Fails Immediately, but boots from USB fine



  • Official comment
    Forrest Smith


    Sorry you're having trouble!

    Even logging into Guest mode can cause an issue,

    Instead, just install from the login screen without ever logging in.

    If you still have trouble, try the cmd line, manual install in the FAQ section.

  • Chris Shewmake

    That seems to be the problem. It is currently installing. I was logged in as Guest on the other laptop and it installed fine, so I assumed that was what was meant as "Not Logged In". Thanks for the fast response!

  • Chris Shewmake


    The laptop worked fine for several hours yesterday, but now it can't find any WiFi networks. It says that WiFi is turned on and it will search for networks, but it just doesn't find any. My other laptops/phones are all connected so its not a network issue (at least I don't think it can be). I have tried turning the wifi off and back on and of course I have restarted the computer several times. Any ideas? Thanks!

  • Forrest Smith

    Hi Chris,

    Does that machine have a physical wifi toggle on the outside of the machine? This is the kind of behavior we typically see when a Dell wifi toggle has been accidentally pushed to "disabled" - CloudReady will still list the wifi as "on" but in reality it has no power.

    You may also want to try this:

    1) Boot to BIOS
    2) Disable Wifi in BIOS
    3) Boot into CloudReady - observe that wifi is disabled
    4) Boot to BIOS
    5) Re-enable wifi
    6) Boot to CloudReady - is it back on?

    Either of those two procedures might help here.

    Best of luck!

  • Chris Shewmake

    Thanks again for answering so quickly. There is no toggle switch, this model has the wifi controlled by the F2 key. Unfortunately, it seems to turn it off when pressed, but it doesn't turn it back on when you press again. After I went into BIOS, I was able to fix it, but I need to figure out a way to disable the F2 Wifi function so that it can't be accidentally turned off. Any ideas on that?

  • Forrest Smith

    Chris -

    This won't fully-remove the wifi toggle from your keyboard, but it might insulate you from the problem occurring as often:

    While logged in, go to Settings > Keyboard Settings and change the toggle for "Treat top row as Fn keys".

    This will likely take away some convenience of the top row keys doing what they're labelled to do, but will help you avoid accidentally turning off your wifi and needing to use BIOS to reset it.

    How's that?

  • Chris Shewmake

    Sounds good, I will try that. I just put a check in the box for "Treat top row as Fn keys". This laptop is for my 8 yr old son, so he tends to press a lot of keys he doesn't need to. Thanks again

  • Chris Shewmake


    I am continuing to have trouble with this one laptop. Every time I power down the computer, the wifi turns itself off. I have to go into the BIOS, turn the wifi off, boot up, shut down, go into BIOS, turn wifi on, boot up and then it will work. So something is making the computer turn off wifi when Cloud Ready shuts down. Any ideas? Thanks!

  • Forrest Smith


    That's troubling - I'm not sure this is something we can solve without a little technical muscle.

    I'll try to get you a cmd line one-liner to run to reset wifi. If that helps, maybe we can run it on each wake-from sleep. Then you'd just need to close and open the laptop to get wifi running.

  • Jeff Miller

    The wifi device may be getting stuck in a soft kill state.
    You can attempt a workaround from the shell.
    When the wifi is not enabled check the values in the files /sys/class/rfkill/*/
    with the command grep . /sys/class/rfkill/*/soft.
    Attempt to drop the soft flag with:
    for x in /sys/class/rfkill/*/soft; do echo 0 > $x; done
    That is, echo 0 into each file named soft for each rfkill device.

  • Kevan

    Hi, i am using my old Dell inspiron 640m to install cloudready. I dint log in either guest or google account, because i couldn't get a WiFi connection at the first place when i plug in my USB installer.

    I then directly install cloudready to my HD. After boot up and in welcome screen which asking me to Select a Network, i cant find any WiFi connection too. I tried the BIOS reboot method, at first it work and show my wifi connection, while trying to connect the wifi, it failed and said network out of range(my router is just beside my pc). After that, i no longer able to find my wifi again...


    Any help will be appreciate!

  • Forrest Smith



    Try toggling wifi off and on using the keyboard shortcut, as well as with any physical wireless button or toggle - sometimes these can reset the wireless to turn it on in a way the software toggle can't.

    You may also want to check if the wifi works in a live-boot Ubuntu environment as a comparison.

  • Kevan

    Hi Forrest,

    I did tried to turn on and off using Fn+ F2 button, but it doesn't work as well. I haven't the Ubuntu live boot, may be will try that. But my laptop wifi is workable when i am using Windows 7.

    Is there anyway to not connect to any network but able to enter cloudready instead of that initial setup screen?


  • Forrest Smith



    If you temporarily connect to Ethernet you should be able to pass that initial network setup screen and from there will be able to login as a guest without any network at all.

Please sign in to leave a comment.