Modified Dell Dimension 2400 with Linksys Wifi WMP54G



  • Official comment
    Forrest Smith

    lm - Thanks for all the detailed info!


    With the age of machine you're talking about here, I'm glad to hear things work as well as you say they do, Not sure we'll be able to improve things too much.


    Installation: Your machine will definitely run better when installed on an HDD - a 7200 rpm should keep boot times under 40 seconds if everthing else initializes well.


    For sound: Your only recourse may be to get (if you so choose it) a USB-headset.


    Hope you find some good use for this machine!

  • lm

    Ok, some follow-ups...

    Wifi/Networking Issues

    I tried since my previous post to use 2 USB wifi dongles I have lying around at home:

    • a (rather shitty) Dynamode 11N USB Adapter which generally sees poor hardware support (and rather limited connection quality), so I wasn't expecting much;
    • a (rather good) TP-Link TL-WN722N USB Adapter which generally has both a decent signal gain and a decent hardware support.

    As I suspected, the Dynamode didn't get much from CloudReady. It sort of seemed to register a bit more than my WMP54G though, as least I had a wifi menu available with an entry to "Enable", but that didn't do anything. 


    However, the TL-WN722N worked liked a charm. Was detected without a reboot when I plugged it in and found my network immediately.

    So, I can at least report that this particular USB adapter is good enough to use with CloudReady and works fine.

  • lm

    Now, off to the bad news...

    CloudReady Unexpected Reboot

    While typing a previous version of these posts, the PC suddenly rebooted. I have not investigated the reason (any recommendation on what to do, apart from looking into dmesg or something like that), so I am hoping it was unfortunate (I may have taped something with my foot, or planets were not aligned, or something benign like that) and not a hardware issue or an overheating issue. I'll see if that happens again.

  • lm

    And for the rest of the bad news (or let's say "lukewarm", for now)...

    CloudReady Performance on this Old Crummy Machine

    Well, the jury is still out on that one. It's OK and definitely works, which I guess is not a bad thing for an OS that saw the light in 2008/2009 considering that machine goes back to 2004/2005. It's a 3.6GHz Pentium 4 with 4GB of RAM and an ATI/AMD Radeon graphics card (can't remember the model right now). It was a sort of decent or even pretty high-end gaming station back then but shows its age now. I'm trying CloudReady to replace the Windows 7 I had it running on, and I'm still not convinced it's much better.

    Lots of things are a bit slow, if only loading web pages (which is too bad, considering it's its primary usecase).

    So, I guess I'll have to try it out a bit longer to see if that works well enough (and if I don't get crashes again). The definite bonus is the relative security of the machine (well, assuming the rolling update are good enough a barrier and its usage model limits attack vectors to a minimum), and its lack of required maintenance, so I think that if performance is on par with the Windows 7, it might win the fight.

    Question though: should I assume it will run faster on the HDD once installed? (it's got 2 similarly aging SATA-connected 7200rpm drives, which so far still have outstanding SMART reports).

    And is there a way to mount a zram folder on the drives or a USB to compensate for the relatively low 4GB RAM ?



  • lm

    Some more reporting on that model...

    It seems to be able to show HD videos on youtube (at least 720p) decently. Not bad! e.g.:

    However, that's when I realized something rather unsatisfactory: I have no sound at all on any of the jack outputs. Don't recall the specs of that machine, if I remember there's integrated audio on the motherboard, and a dedicated Creative soundcard.


  • lm

    So basically I have this choice of sound cards when I use alsamixer:

    • CRAS (default, ChromiumOS Audio Server - does not work),
    • Intel ICH6 (integrated chipset - does not seem to work),
    • SoundBlaster Audigy 2 ZS [SB0353] (dedicated soundcard - does not seem to work).

    That's really too bad, especially as the Audigy was a decent audio card.

    No matter what I enable in alsamixer, I don't get any sound (unmuted all channels, raised volume, switched between all cards).

    It seems like every time I re-open the alsa mixer I'm abck to CRAS, so it may not really give much of a damn about what I'm asking it to do, sadly.


  • lm

    Actually didn't even think of trying with a USB headset. I don't have one, but I'll give it a shot.

    It's a pity to lose some of the advantages of this machine, as it had decent graphics, audio and wireless cards... But I guess it's still better than not using it for anything.

    Sadly for now its primary user decided she wasn't so keen on CloudReady. Too much deviation from the Windows 7 installed on it and that she's accustomed it. Really too bad, as performance wise for most of what she does on it it was much better. E.g. videos on Youtube don't even lag in 720p in fullscreen, whereas they do on the Windows install. Videos are clearly not so smooth as they should be though, so I suspect the video card isn't used either, but I'd rather have imperfect image and no lag than the other way around.

    I'll have a look for a USB headset and see if that works fine. For the installation, I guess I'll try on another machine. Boot time was already better than 40s by the way, as far as I can remember. More like 20 or 25. Really not that bad.

  • Forrest Smith



    Glad to hear performance was improved, but sorry that your user wanted to keep it set up the old-fashioned way. Not eveyone is ready for the revolution ;-)


    Hope your next machine and user-base are more compatible. Audio jack failures are not too common, so you may not even need to get a USB-headset if you put CloudReady on a different machine.

  • helpechoes

    So the USB WiFi worked on this machine? The

    TP-Link TL-WN722N USB Adapter anyway.


    Is that one of these big ones?


    I wonder if one of these little suckers would work:

    - TP-LINK TL-WN725N USB Wireless Adapter - N150


    I bought a cheap USB Dongle one on Amazon from Hong Kong

    TOOGOO(R) Mini 150M USB Wireless Adapter Dongle WiFi Lan Network Card IEEE 802.11b/g/n 

    But it does not seem to work. - it just says. No network.




  • lm

    Thanks @Forrest... But we know that already, that's exactly the dongle I said I used.

  • Forrest Smith

    Sorry Im - just wallpapering the forums to make sure people get notified.



Please sign in to leave a comment.