Install / Boot issue

Comments

15 comments

  • Forrest Smith

    Daniel - 

     

    Try installing in UEFI mode, and try to recreate the flow of the special install instructions at this link.

     

    I think the rub is that your machine needs very careful attention to boot-path when in UEFI mode - that's what's specified in that link. You may need to both specify the boot path while booting, AND add a boot option to your BIOS of the same path after install is complete.

  • Daniel Malan

    Thank you for the advice I shall try it out. I'm just going to reimage the USB again with a clean download as well. Will keep the thread updated

  • Daniel Malan

    Hi Forrest Smith,

     

    Ok i found out what my issue was.

    Apart from having to create a custom boot option in the BIOS i also had to enable my PXE OpROM support. This allowed it to boot perfectly into ChromeOS without any issues.

     

    Settings for the BIOS: 

    ADD BOOT OPTION: >> (name of boot order) Google ChromeOS

    SELECT FILE SYSTEM: >> (should already be the HDD/SSD)

    PATH FOR BOOT OPTION: >> \EFI\BOOT\BOOTX64.EFI

     

    Then select create and then add it to the boot order as second boot after your DVD drive and before any USB Legacy/UEFI boot options.

     

    I later encountered an issue again after configuring a few custom apps and had to reinstall but everything is running fine now with no lag or any other issues. But to others reading this post please be advised that this worked for my machine, Asus S550CA with a mSATA SSD and HDD installed. It may not work for yours. For other users to help out my base chipset is an Intel HM76 / C206 express chipset.

     

    The video output works 100% but of course due to chipset limitations only one extra monitor at a time. Touchscreen and Touchpad both work perfectly with the same functions as using the original Windows environment as well as all the fn Function buttons work accordingly to their command.

     

    Once again thank you for the help

  • Nigel H

    This was a very helpful post and I've now solved a similar problem on an ASUS F202E (Australia)

    Install proceeded without problems but no booting on restart.

    Steps I found successful using Daniel's and Forrest's tips.

    1. Turn off Secure Boot and Fast Boot
    2. Enable PXE OpROM (this is so you can add a Boot option)
    3. ADD BOOT OPTION: >> (name) Google ChromeOS
    4. SELECT FILE SYSTEM: >> (should already be the HDD/SSD)
    5. PATH FOR BOOT OPTION: >> \EFI\BOOT\BOOTX64.EFI
    6. Select "Create" (options will empty for new input but it has been created)
    7. Change boot order and move ChromeOS to Boot #1 option
    8. Reboot

    Can confirm all Function keys, Touchscreen, Touchpad, USB mouse and Keyboard working perfectly.

    This slow frustrating laptop is now a pleasure to use and suits me as a mobile work device because I'm using Google products and Drive daily.

    Thanks guys.

  • Daniel Malan

    Glad to hear you could get your rig up and running Nigel. I've shared this as much as I can my side so for anyone who wants to run a ChromeBook can. And once again thank you Forrest for the assist you gave me too. 

     

    Cheers guys 

  • brunoweinstein

    Hi there!

    I'm having kind of the same problem, the only difference that I see between my BIOS and the settings you areg suggesting is that my file system is different than this HDD/SSD.I attach a picture of what it says.

    Even if I set the path exactly as you say it here, it wont boot on Chromium, back to the bios. If you can help me please! Thak you.

    The laptop is ASUS X401A

    Cheers!

  • Forrest Smith

    HI Bruno,

     

    That looks normal - it just means the HD is connected via PCI internal connector,

     

    Make sure you have secure boot off, UEFI enabled, Legacy boot off/CSM disabled, and then make sure your PCI boot option has a "Path" that matches the descriptions Nigel and Daniel posted.

    Also note that you need to make sure the boot option is added and then shows up in the BIOS.

     

    This issue described with the x401u is that, if no other boot options are currently in the list, then adding a new option (even with the path perfectly specified) will not permanently add a boot device to your list and, when booting back into the BIOS afterwards, the boot options list will be empty.

    This is the reason that enabling PXE is necessary - you can avoid this buggy behavior as long as some other boot option, like PXE, is enabled. Then add the option as described, then save and try again. 

     

  • brunoweinstein

    Forrest, thanks for the help.

    But i cant find where to set this "secure boot off, UEFI enabled, Legacy boot off/CSM disabled"

    The path im setting is C:\EFI\BOOT\BOOTX64.EFI

    And the PXE enabled. What i get is a DOS screen where it says at the end "Reboot and select proper boot device or insert boot media in selected boot device and press a key" 

    Keep in mind that ive already installed the cloudready from UEFI usb and made every step as said.

    Thank you!

     

  • Forrest Smith

    Hi - 

     

     

    1) Those are all separate settings that may or may not be in your BIOS under different menus:

    + secure boot

    + UEFI mode

    + Legacy boot mode

    + CSM 

    Any of those should be adjusted if you can find them in the boot settings or security settings sections.

     

    2) The linked page in this thread and other comments don't use "C:" in the beginning of the path - make sure you specify it exactly as listed here.

  • Jakub

    I hereby confirm - Steps from 2 to 8 also helped for my ASUS X501A.

    Thanks so much you guys!

    I knew it there's gotta be a new path that has to be added! :)

  • Zen Robert

    Thanks so much Daniel Malan for solving my problem with my Asus VivoBook X200CA-DB02. It all worked.

  • Leonel

    Thank you! Really! Thank you very much!

    Steps 1 to 8 worked well on an old Asus X202E.

    Best

     

  • Lou

    I am very frustrated with getting my Dell Inspiron 14 with a 32 GB SSD to boot off of the bootx64.efi file I see in the menu tree, for some reason when I hit enter on the file, it opens a box to manually type the file name, I've tried the name alone, and the path as described above: \EFI\BOOT\BOOTX64.EFI, I've even tried flipping the slash marks and getting rid of the leading slash mark. But any way I do it, as you can see, the file extension is cut off. I saw on one of the screens somewhere that the maximum number of characters allowed was 17. What the heck is going on? It boots off of my USB drive if I set it to "Legacy" and "USB", but in UEFI, it won't access that file even though it shows up. 

    By the way, files and paths are all lowercase, but the BIOS only types in capital letters.

    See BIOS screen here:

    https://drive.google.com/drive/folders/1GtmJOimH8ryLTumbj5iEl6KvVtDQDIKT?usp=sharing

     

    The screen below is just the latest try, I even tried the 32 bit version every which way; with a file path, without one, backward slashes, forward slashes, etc.

  • Spencer Simko

    Ok I am unable to find PXE opROP. Is it the same thing as enabling network boot? Here's an image of the only place I was able to find the letters PXE.
    https://photos.app.goo.gl/JGloSZCdUs5WagpV2

  • Nigel H

    Yes Spencer, you should then be able to add a boot option, even though the option you're adding isn't on a network.

    Be sure to disable Secure Boot, Legacy Boot and Fast Boot if available. UEFI should be enabled.

    All other steps are in my original post from a couple of years ago. Forrest has some helpful tips in this thread also.

    Good luck!

    Cheers, Nigel

Please sign in to leave a comment.