Need to permanently disable auto-updates



  • Forrest Smith

    Hey Charles - 


    Here's hoping that the patch we'll be shipping soon might help you get back on v50.

    But if not - Settings>About Chromium OS>More info>Change Channel> Dev


    This will put you on a release channel which we are not currently shipping anything on.

  • Charles E Dayhoff

    Thank you Forrest! You are the man! Lightning fast!

  • Charles E Dayhoff



    In 46.1 there is no "Change Channel" button.  Is there a way to do it as a cmd?

  • Forrest Smith

    not that I know of, but there should be a way to change to dev channel in v46 - I'd search a bit more in the settings menu, and then start googling for v46 dev mode

  • Lasse Bachmann

    It's relatively easy to disable automatic updates:

    The automatic updates are handled by the update_engine, service started at boot: If you disable this boot configuration, it won't check for updates at all!

    Here's how to do this (type or copy / paste lines not starting with #. DO NOT copy "<enter>" ;-) :


    Open crosh by pressing "Alt + Ctrl + t"

    #1 drop to linux shell:

    shell <enter>

    #2 mount system writable (password is "chrome", without quotes):

    sudo mount -o remount,rw / <enter>

    #3 disable update-engine.conf by renaming it:

    sudo mv /etc/init/update-engine.conf /etc/init/update-engine.conf.backup <enter>

    #4 reboot your system:

    sudo reboot <enter>


    After the reboot your device will no longer check for updates! To re-enable automatic updates follow the steps above, but replace #3 with the following:

    #3 enable update-engine.conf by renaming it:

    sudo mv /etc/init/update-engine.conf.backup /etc/init/update-engine.conf <enter>

  • Forrest Smith

    LAsse - Such a helpful walkthrough.


    I hoe you don't mind - I made an article reiterating it  so everyone can find it easier. Let me know if you'd prefer I don't name you.

Please sign in to leave a comment.