Installation not working

Comments

18 comments

  • Forrest Smith

    Hi Roland - 

     

    What type of internal storage are you trying to install to? And what size? and in what machine?

     

    Also - are you jsut running dualboot install or standalone too?

  • Roland Klein

    Thank you for looking into this!

    I am trying to install it to a SATA internal HDD. (Hitachi 500 GB, without a SSD cache) I have to partitions, whereby I have almost 45 GB of free storage on the 130 GB system partition and about 23 GB on the other one. 

    I would like to install it as a dualboot. A standalone is not really an option for me. 

    Further Specifications of my system are:

    OS: Win 10
    Machine: Samsung Ultra Series 5 (np535u3c a02de)
    Processor: 2x2.1 GHz AMD (A6  4455M)
    GPU: AMD Radeon HD 7500G
    RAM: 8GB DDR3 SODIMM
    Chipset: AMD A70M

  • Svyatoslav Gryaznov

    Hi,

     

    I'm experiencing similar problem during both standalone and dualboot install. Laptop is Lenovo X230. Tried installing only on second (M-SATA) SSD.

  • Support Team

    Svyatoslav-

    When you say your errors are similar do you mean that you're getting the exact same error output when installing in UEFI mode?

    ERROR: Entry outside of valid region
    ERROR: -i 26 -l RWFW -b 976773201 -s 16384 -t CAB6E88E-ABF3-4102-A07A-D4BB9BE3C1D3

  • Svyatoslav Gryaznov

    Abram,

     

    Sorry for the delay. Log error isn't the same. Here's the output (standalone install):

     

    initctl: Unknown instance: 
    This will install from '/dev/sdc' to '/dev/sdb'.
    This will erase all data at this destination: /dev/sdb
    32+0 records in
    32+0 records out
    16384 bytes (16 kB) copied, 0.00226008 s, 7.2 MB/s
    33+0 records in
    33+0 records out
    16896 bytes (17 kB) copied, 0.0040896 s, 4.1 MB/s
    WARNING: Primary GPT header is invalid
    ERROR: Entry outside of valid region
    ERROR: -i 16 -l STATE -b 14831682 -s 485286476 -t EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 

     

  • Tim Shaw

    I had a similar problem - did you manage to resolve it?

  • Forrest Smith

    Svyatoslav, 

    I notice that your error shows that the computer is trying to install from sdc to sdb- this is particularly odd,  since it suggests you have three storage devices on your machine at the time of install.  Do you happen  to have an extra USB inserted? Or perhaps your hdd has one of those fancy ssd caches? 

     

    Almost always,  sda is the destination device,  or at least involved. 

  • Roland Klein

    Just a quick follow up:

    it worked. I downloaded the newest build and made sure once more that everything is set as required ie secure boot off etc. Moreover, I deleted all the partitions from earlier installation attempts. I then tried it with the GUI. Although it took a bit longer than 20 minutes it eventually worked. There are a couple issues, which I'll address in different threads, but it is essentially running now. 

  • Franz Keferböck

    UPDATE Oct 01, 2018:

    As the "mount -o remount,rw /" command is no longer working with recent versions here is another way to overcome the "wrong-disk-selected" problem:

    echo 1 > /sys/block/sdX/device/delete

    where sdX is the device you want to ignore (in my case the HDD the kernel maps to /dev/sdb

    OLD (and complete) ANSWER: 

    I had the same problem, and your proposal did not solve it I'm afraid; still, I could fix this issue and this info might be of value for others too (maybe a (fix upstream):

     The devil's hidden in 

    /opt/neverware/cgpt_reader_guy.py

    in line 225:

    target_drive = disk_util.choose_destination_device_path()

    which is called by the installer and determines the drive for which the boundaries for the partitions are defined.

    Now, this command returned "/dev/sdb" (the installed HDD) in my case - and totally ignored my SSD "/dev/sda" which happens to be the drive I asked the installer to chose as target.

    Long story short: the installer tried to create partitions on the much smaller /dev/sda based on the layout of /dev/sdb

     

    Dirty fix:

    • "mount -o remount,rw /" # re-mount "/" as rewrite
    • "vim /opt/neverware/cgpt_reader_guy.py" # edit the file
    • change the line that says "target_drive = disk_util.choose_destination_device_path()" (towards the end!) to "target_drive = '/dev/sdX'" (where "/dev/sdX" is the drive you want to install to)
    • re-run the installer, again providing the --dst "/dev/sdX"

    I'm sure there's a nicer way to fix this, but I honestly lack the time - for anyone familiar with the installer this should however be a no-brainer ;)

    Hope this helps!

    -franz

  • Robert Flack

    I ran into this error as well, but it wasn't an issue of target drive selection. Instead I believe it was due to an integer overflow causing the secondary GPT header to appear to be at a negative position which lead chromeos-install to try to create a negative size data partition.

    To check if this is happening to you, run cgpt show /dev/sda and look at the final two lines, in my case:

      -387938161          32          Sec GPT table
      -387938129           1          Sec GPT header

    As you can see, the offset of the secondary GPT table is negative, this leads cgpt_reader_guy.py to return a negative last logical block which results in the following attempted block creation when running chromeos-install:

    # chromeos-install --dst /dev/sda --debug --yes
    + : 14831682
    + expr -387938162 - 14831682
    + partition_size=-402769844
    + /usr/bin/cgpt add -i 16 -b 14831682 -s -402769844 -t data -l STATE /dev/sda
    ERROR: Entry outside of valid region
    ERROR: -i 16 -l STATE -b 14831682 -s 18446744073306781772 -t *** 

    This being a negative partition size is invalid. I believe the root cause of the error comes from cgpt.c truncating the integer type on a large hard drive (1.8TB in my case).

    TLDR; if this is your error you can fix it by editing /opt/neverware/cgpt_reader_guy.py and just hard-coding the return value for def get_last_free_block(lines). The value you should use can be found by running cgpt show /dev/sda -d and finding the value for "Last LBA".

  • Bill Grau

    I am trying to manually install to an external SSD drive, here /dev/sdc -

    none of the advice above worked for me,

    including modding /opt/neverware/cgpt_reader_guy.py

    I keep getting the output:

    This will install from '/dev/sdb' to '/dev/sdc'.
    This will erase all data at this destination: /dev/sdc
    Are you sure (y/N)? y
    32+0 records in
    32+0 records out
    16384 bytes (16 kB, 16 KiB) copied, 0.00268689 s, 6.1 MB/s
    33+0 records in
    33+0 records out
    16896 bytes (17 kB, 16 KiB) copied, 0.00564357 s, 3.0 MB/s
    WARNING: Primary GPT header is invalid
    ERROR: Entry outside of valid region
    ERROR: -i 16 -l STATE -b 14864450 -s 110180940 -t EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 


  • Bill Grau

    Doesn't matter, easy solution is to use command line to install an older version of cloud ready, & if using an external USB SSD, let it upgrade to the latest v60+, I used v44 for the trick, but it will be nice if you fixed the command line installation for the new releases.

  • Forrest Smith

    Bill,

     

    Glad you got it worked out but - 

     

    what size is your target device /dev/sdc ?

     

    We fixed a bug, coming in v66.4 this week, that fixes issues with install targets that are less than 16 GB. I wonder if that is the issue here? maybe v44 didn't have this early problem.

  • Bill Grau

     target device /dev/sdc was 64GB SSD

    the one for Acer C720P was the internal official one which is 16GB (though I upgraded it long ago to 64 GB) - but using the gui installer created problems with the shell as I told you.

    what I wanted was install to a USB with ability to upgrade, that can be done using a fixed disk USB, so using a SSD or mSSD with usb adaptor solves it.

    I now have 2 copies of cloudready which I can use on all my devices, including Acer C720P, with having to contend with re-inputting details everytime I change device.

  • Bill Grau

    Your new release v66.4 does not solve the issue, I tried the command line on 2 targets 16GB & 32GB,

    still gives same errors I posted before, so that was not the bug your dev team addressed.

  • Bill Grau

    here are outputs

    for 32GB USB (mSSD fixed drive), 16GB USB (stick, removable) respectively

    WARNING: Primary GPT header is invalid
    ERROR: Entry outside of valid region
    ERROR: -i 16 -l STATE -b 14864450 -s 102366924 -t EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  • Bill Grau

    TBH, I believe it is a Google chromeos-install issue, they sabotaged it to disallow cloning to usb.

    I am grateful to have saved v44 to use on fixed drive USB's.

  • Bill Grau

    I posted it on XDA forum,

    it is a Google chromeos-install issue

    Google Chrome OS cloning - with examples using Acer CB C720P

    https://forum.xda-developers.com/hardware-hacking/chromebooks/google-chrome-os-cloning-examples-using-t3810501

Please sign in to leave a comment.