ASUS Vivobook E200HA

Comments

40 comments

  • Forrest Smith

    Hi Joshua,

     

    I don't really know if we can help - this device is quite new and compact, so the keybaord and trackpad may be connected in a way that we don't have support for yet, or the processor (Atom Z8300) may not work right with CloudReady yet.

     

    Try putting the laptop to sleep for a few minutes and then waking it up - sometimes re-initializing will bring devices and components to life that get skipped/missed on startup.

  • ktc3

    I try too to install Chrome Os on my Asus E200HA and I have the same problem :(

  • philippe salort

    hi

    I have the same problem with my asus vivobook E200HA. There is no solution ?

     

     

  • deleted

    Wait for kernel 4.6. That's all :/ copy from

    http://askubuntu.com/questions/753964/installing-ubuntu-from-usb-on-asus-e200ha

    Some of the problems are related to UEFI, others to keyboard & mousepad. Only the most recent kernels, 4.6.3 and above seems to work ok with the keyboard & mousepad, and some distributions are far better at handling UEFI than others.

     

    Don't know what v53 will be rolling with. I'd assume 4.4.21? https://chromium.googlesource.com/chromiumos/third_party/kernel.git/+/v4.4.21

  • Solomon T

    Anyone got follow ups on this specific laptop?

  • Sorakatzu

    We need to get this working guys!

  • Alice Ruppert

    I have the same issue with my Asus e200HA. I previously had windows 10 and lubuntu on the same machine and the keyboard/trackpad worked with both.

    Is there anything one might try to fix this?

  • Forrest Smith

    Acer machines often need their BIOS adjusted to enable touchpad by turning on "Basic" mode. An Asus might have something similar, so look for that.

  • Jacqui Cul

    I have same problem - I've just installed ClourReady, and keyboard and trackpad don't work.

     

    Any updates on this?

  • Joseph Honnoll

    Nope. Install Windows and Wait for CR to Support the Laptop which will take some time....

  • Sullies T

    Please I want support on this... I cannot stand Windows 10 on this computer, I would really love cloudready on it :(

  • Joseph Honnoll

    Yeah I know. Have you tried the Latest Build? My Guide LINK

  • Muli Coh

    Does the latest build that you've mentioned supports the Asus E200HA??

  • Joseph Honnoll

    Umm far as I know nope. The Kernel only gets updated when a New Build comes (Duhh!) 

     

    So your out of luck. Sorry

  • Retch

    I tried it today, but unfortunately Keyboard and Mouse only works over USB, so the intergrated keyboard ist useless. Sound doesn't work either. Hope there will be a never good version with support.

  • Sorakatzu

    Since 2 years CloudReady has been doing nothing about it :(

  • Joseph Honnoll

    Sir there are a bunch of laptops to sort through. Wait for new builds and just see if it works

  • Retch

    I tried this chromium os build https://arnoldthebat.co.uk/wordpress/chromium-os/ and mouse and keyboard worked fine, but the wifi doesn't worked.

  • Joseph Honnoll

    Hmm you could replace the WiFi Card. Follow my Guide

     

    Though can't find a teardown video or Images of the product

  • Retch

    I think i cant replace the wifi card. I owned a Windows 10 Tablet for 50 bucks, so with bay trail atom chipset and there was no pcie wifi card, only onboard wifi. The e200 is cherry trail, so it is a tablet chipset in a netbook and we cant replace the wifi card due it is onboard. Is there a way to bring the drivers for mouse and so from arnoldthebat to cloudready? Or to bring the wifi driver from cloudready to arnoldthebats Chromium build?

  • Joseph Honnoll

    Nope. You'll have to wait for a New Kernel which means a new Build. Though you could use a USB WiFi Adapter for the Moment

  • Retch

    Oh thats a pitty. Thank you

  • Retch

    I startet Flint OS https://flintos.io/ and Wifi keyboard and mouse works. But it is not usable right now, because the audio seems to be not working, and there is no way to install flash or mp3 codec. Youtube loaded a video in html5, but there was no audio.

    We  just can wait for a better experience.

  • Joseph Honnoll

    I'm pretty sure ASUS is now just wanting Windows based Laptops where now you can't install any other OS with without issues. Same thing HP is doing with only white listed products for their laptops 

  • Retch

    Yes this is not good. I tried to install linux, but there is no wifi working and no sound. It's Intels fault because the claim the source code and don't give it to the developers.

  • Forrest Smith

    Retch - have you had a chance to try again on v61 of CloudReady? We've made major updates that should help to some extent.

  • Retch

    @Forrest Smith,

    I'll try it on the weekend, i'll give information back about it. Thank you

  • Retch

    @Forrest Smith

    I booted it from USB, so a live usb. Almost all works good, but Touchpad is not working. Keyboard works good, and has QWERTZ layout which is good for me, but a mousecourser i only get when i plug in a usb mouse. When you fix the touchpad, I'll do a full install.

  • Forrest Smith

    Retch,

     

    When livebooted, you might want to try this:

     


    1) Log in

    2) Press ctl+alt+t to open a terminal

    3) Type in "shell" and hit enter

    4) Confirm that the yellow "crosh" prompt is now a green "chronos@localhost" prompt

    5) run cmd

    sudo mount -o rw,remount /

    6) run cmd

    evtest

    then hit ctl+c

    7) Look at the output of evtest and find your touchpad's line. Check which "event" number it corresponds to. (Post a screenshot or copy/paste here if you're unsure)

    8) Now, keeping that event number in mind, run this cmd:

    sudo vim /etc/chrome_dev.conf

    9) Inside vim, arrow down to the very bottom

    10) Hit "esc" followed by "i" to put the machine in "input" mode

    11) Now add a line that says:

    LIBINPUT_EVENT[#]=yes

    where you replace [#] with the event number you noted above.

    12) Hit "esc", then ":wq!" and then "enter" to save the change

    13) reboot

    14) Check if behavior is better, worse, same, etc and let me know.

  • Retch

    @Forrest Smith

    First i've to thank you for your effort.

    I followed your tips, but evtest gives me 14 events/devices also Asus Keyboard, but nothing that has something to do with touchpad.

     

    Edit: After the evtest command, it shows the devices (but no touchpad) and the os freezes after it's shown the devices.

Please sign in to leave a comment.