Dell XPS 13 9360 (7th Gen i7) - 98% Working!!!

Comments

10 comments

  • dragon788

    And I just ran across a fix for the touchpad that makes it closer to 99% (just missing hardware video decoding for better battery life). The same fix for a prior XPS 13 generation works perfectly for this one.

    https://neverware.zendesk.com/hc/en-us/community/posts/115007882667-XPS-13-9343-works-with-small-modification

    0
    Comment actions Permalink
  • Forrest Smith

    Thanks for posting all this info, and for testing such a slick device! Glad to hear it's such a great experience. If you have a chance to try one, let us know if the Dell stylus (or any other active stylus) works. My HP Spectre 13 has very similar specs and an active stylus that CloudReady picks up and supports automatically (and not just as a capacitive style).

     

    Note that the issues with video tearing shooould be resolved, at least in part but hopefully in whole, when v61.4 comes out. We hope to re-enable hardware accelerated decoding in v63 (February) as upstream Chromium adds in the updated modes you mention in v62 (which we're skipping).

     

    Cheers!

    0
    Comment actions Permalink
  • dragon788

    So I may have to revise my estimate down to 95% working, but that 95% is pretty awesome. The one (big) thing that is still missing would be the ability to use my laptop's USB-C/Thunderbolt 3 port for more than simply charging. I plugged in a Dell USB-C/USB3 dock and while the XPS13 would charge it would not utilize the connection with the dock to display video. When I switched the connector from USB-C to USB3 I was able to see the USB devices on the hub initialize and utilize the wired network connection the hub provides, but the video ports sadly were not usable in my brief testing. They require a DisplayLink driver I'd imagine isn't present in ChromiumOS but IS available in ChromeOS by default.

    The other dock I tried was a Thunderbolt 3 dock (Dell TB16) and while it also charges the laptop it doesn't affect the dmesg output at all when plugged in other than the power state changes. I believe some of the support for these may come in the newer kernels (4.10 and higher, 4.13 has a bunch more fixes) but for now I'm going to play around with a few other DisplayLink devices and see if I can get them working or not in CloudReady or if it requires poking some binary blobs into place to allow it to act as a display.

    0
    Comment actions Permalink
  • Forrest Smith

    Thanks again for detailed feedback and testing.

    I know Thunderbolt isn't supported in Chromium, but USB-c generally is, and we worked on DisplayLink support (at least over USB 2) for v59 and v60.

    I don't have any USB c docks (thunderbolt, DisplayLink, or otherwise) so I can't test this now against our devices in house.

    Any chance you have a Chromebook to test this dock against?

    Other question I have is - what specifically did you do when you say you switched the connection from USB c to usb 3? Did you change a mode on the dock? Or change the physical port you used to connect the dock?

    0
    Comment actions Permalink
  • dragon788

    Yeah I've tested the Dell D6000 dock with a number of USB-C enabled Chromebooks and it works great with them. I think the issue on the 9360 (and probably other systems with Thunderbolt 3) is that the USB-C is a function of the Thunderbolt controller so the kernel needs to initialize the Thunderbolt functionality to also be able to use the USB-C.

    To switch from USB-C to USB3 there is a physical adapter tethered to the cable that takes the USB-C and converts it to a USB-A male connection and it is wired to handle the reversible nature of the USB-C connector so you can put it into the adapter either way.

    I also have a Plugable USB-C dock floating around that I'll test with CloudReady at some point to see if it works differently at all.

    0
    Comment actions Permalink
  • dragon788

    I've also recently noticed that since swapping to a Broadcom wireless card that I'm running into the no wireless after sleep issue but I hadn't noticed when I had the default Killer wireless model. https://neverware.zendesk.com/hc/en-us/community/posts/115010047668-No-network-connectivity-after-resume-suspend-wake-wifi-and-ethernet

    I'm going to try with the Killer and an Intel wireless card and see if I still see the same behavior.

    0
    Comment actions Permalink
  • dragon788

    I got a chance and tried with the Plugable USB-C dock and it also isn't recognized as a device but will charge the XPS 13 just fine. It definitely appears to be either the TB3 firmware or USB-C firmware isn't being loaded in CloudReady.

    0
    Comment actions Permalink
  • Forrest Smith

    Hey,
    Thanks for following up! I bought a couple USB c docks and am finding they work completely, but only under specific circumstances.

    If you reboot with the devices plugged in, or reboot and then plug in the USB c docks once, all USB devices (storage, peripherals, audio, Ethernet) work, as does the mini-display-port functionality that powers the HDMI port on the dock. Power passthrough works too.

    After subsequent unplug/replug events I find only the power and mini-display-port functions work. USB devices , or anything over the USB protocol as listed above, aren't picked up. (The dock seems to shown indicator lights, so it's pretty clearly CloudReady's fault :-( )

    I haven't tested anything that uses DisplayLINK but I expect that will work, but only in the circumstances where USB works as described above .

    Can you test/compare whether reboots help in the way I'm seeing?

    0
    Comment actions Permalink
  • dragon788

    Forrest, the behavior you are probably seeing is that most systems with Thunderbolt have some security settings in the BIOS that require either "No security" to allow devices to connect and disconnect automatically, or they need set to "User security" in which case you need a utility like `boltd` to communicate with the device and add it to an authorized list. In most cases on Dell systems they are set to automatically trust certain docks if they were present before/during boot, otherwise if they are plugged in later (after an unplug maybe) it wants to "authorize" if the setting isn't "No Security".

    https://github.com/intel/thunderbolt-software-user-space

    https://gitlab.freedesktop.org/bolt/bolt

    0
    Comment actions Permalink
  • Forrest Smith

    We've since see this behavior fixed actually - our engineering team made changes to our kernel - No BIOS change needed.

    0
    Comment actions Permalink

Please sign in to leave a comment.