Boot problem after install

Comments

15 comments

  • Forrest Smith

    I don; think the install warnings about GPT are the problem - if you are able to boot from internal storage (even manually selecting it) then that's not the problem.

     

    When you manually boot CLoudReady from the internal SSD, what keys do you press and what options do you see on the screen? A picture of the boot menu would be good to look at.

    0
    Comment actions Permalink
  • Marc

    Hello, and thanks for replying.

     

    After pressing power button, i've the BIOS screen.

    As you can see, UEFI boot is enabled:

    Nothing interresting in the "boot" tab. Except the boot priority :

    In "Exit"tab, i have the "Boot override" option. In order to boot, i select "P0: SAMSUNG...". Then CloudReady boots correctly.

     

    The strange thing is that it boots directly from USB. I don't have to override. Or maybe the USB key is booting in legacy, since i cannot disable legacy boot ?

    0
    Comment actions Permalink
  • Forrest Smith

    Thanks for the photos! 

    1) Is there another "Boot" menu not shown in your pictures? I see the boot order priority, but I believe there should be another menu, one level higher, which shows other boot options. can you send a pic of that?

     

    2) Is there a way to interrupt startup and, instead of going to the full BIOS, access a one-time-boor menu? That might involve pressing esc, F2, F4 ... or really any other Fn key... during startup to interrupt boot. It should, if it works, bring up a smaller menu of boot options where you can, on a one-off basis, select which to boot from.

    0
    Comment actions Permalink
  • Marc

    You are welcome.

     

    A small video of the problem: https://youtu.be/iSiZCE3FloI

     

    1: The boot tab isn't very interesting. Only TPM and PEX options. Here's a pic :

    2: This PC is sold without keyboard, so i think the BIOS is minimal. To use it, i have to hit Vol+ / Vol- with some combination of keys.

    The "ESC" key shows a boot device selection screen. If i select "P0: SAMSUNG ..." it will boot. It's the same thing that the "boot override" option in bios.

    My problem is; why isn't it automatic. This disk is the only boot device on computer... with Windows, it boots correctly. I dont understand.

    0
    Comment actions Permalink
  • Forrest Smith

    Hi,

     

    Some devices' BIOS have some corners cut and they hard-code a boot path meant for Windows. If that's happening here, it might be causing the device to, by default, look for a Windows EFI file that is missing.

     

    Here's a way to fix that issue:

    (Note that, if you try the fix below and it isn't the correct solution for your current problem, you may need to reinstall)

     

     

     

    1) Boot into your internal CloudReady install, and log in

    2) Press ctl+alt+t to open a terminal

    3) Type in "shell" and hit enter

    4) Confirm that the yellow "crosh" prompt is now a green "chronos@localhost" prompt

    5) Run the cmd 

    sudo disable_verity

    6) As long as that command doesn't throw any errors, you can power off the device now

    7) Next, re-insert your USB installer and boot from that 

    8) Log in and jump to a terminal in the USB liveboot environment (steps 1-4)

    9) Run the command:

    /opt/neverware/bootloader.py winefi-quirk /dev/sda

    10) As long as that command doesn't throw any errors, you can, again power off.

    11) Remove USB and attempt to boot from SSD without any special steps

    0
    Comment actions Permalink
  • Marc

    Hi, 

    I've just tried your solution. I think you forgot "sudo" in step 9, i had "permission denied. So i added it.

    I still can't boot, BUT, now it's a black screen, not the BIOS.

    If i enter BIOS manualy, i can see an UEFI entry. So i think you are right, the PC BIOS is hard coded for windows !

    If i select the "UEFI" entry in the override boot menu, it  shows a black screen.

     

    That seems so close !!!

    0
    Comment actions Permalink
  • Forrest Smith

    Good catch on the "sudo" in #9.

     

    It does seem like the quirk was successfully applied ... but I'm not sure what the problem is still. 

     

    Have you tried disabling UEFI mode? It's worth disabling it and seeing if either of the two boot options work. If neither does, leave UEFI mode disabled and try reinstalling with it disabled and see if that works any better. 

    0
    Comment actions Permalink
  • Marc

    I've tried with UEFI disable , it boots on BIOS.


    Just tried to reinstall with UEFI disabled:

    Install is OK, but boots on BIOS. I can select "P0 bla bla" boot override, and it'll boot on CloudReady.

    It's the same behavior than before. I assume even with UEFI enabled, it was using legacy boot.

     

    So... with UEFI disabled, i can't boot (directly) from internal SSD, but it's OK from USB.

     

    I've removed the internal install with a bootable linux, and tried UEFI from USB. It boots up, but since i can't disable legacy boot, i presume it tries UEFI, and turns back to legacy boot...

     

    So my problem is:

    Can boot from USB, probably in legacy, straight to the login screen.

    Can boot from internal SSD in legacy, but have to select the boot device manualy.

    Can't boot from internal SSD in UEFI : black screen.

     

    Is there a way to know if it boots in legacy or uefi mode ?

    0
    Comment actions Permalink
  • Forrest Smith

    I think you're accurate in all your summary.

     

    You can check these assumptions and confirm you rUEFI vs Legacy Boot mode whenever you're booted into CloudReady, from USB or internal, but:

     


    1) Log in

    2) Press ctl+alt+t to open a terminal

    3) Type in "shell" and hit enter

    4) Confirm that the yellow "crosh" prompt is now a green "chronos@localhost" prompt

    5) run cmd

    ls /sys/firmware/*

    6) If you see a directory called "efi" in the output, then you're booted in UEFI mode. If not, you're Legacy mode.

    0
    Comment actions Permalink
  • Marc

    Hi ! Sorry i was not at home.

     

    So, i've tried some things, without results.

     

    --> Booting from internal SSD seems to be legacy. No "EFI" folder, and it's logical since i choose "P0: samsung blabla" in BIOS, and not "UEFI something".

    --> So i tried to apply your procedure "winefi-quirk" to the USB key. BIOS then show a "UEFI Usb Disk drive". A straight boot is OK, and a "EFI" folder is present.

     

    --> Booting from internal SSD in UEFI is still black screen, but just before i can see a "Welcome to GRUB!" message. 

     

    Very strange thing, if i plug the USB key when screen is black, it'll load ClourReady from the USB device (in EFI mode ) !!

    https://youtu.be/UetZ_mSBA5c

     

    So, looks like GRUB isn't capable of finding the local install ??

     

    0
    Comment actions Permalink
  • Forrest Smith

    Hi again,

     

    Please try these steps in this order:

     

    1) Re-image USB device

    2) Apply EFI-quirk to the USB

    3) After installing from the USB in EFI mode, apply the EFI-quirk to the SSD

    4) Now try booting - get anywhere?

    0
    Comment actions Permalink
  • Marc

    Hi,

    I've tried, with some problems.


    1) Re-image USB device

    --> OK

    2) Apply EFI-quirk to the USB

    --> OK

    3) After installing from the USB in EFI mode, apply the EFI-quirk to the SSD

    --> Unable to install. Tried 2 times. So i used a bootable linux to remove all SSD partitions, and create a MS-DOS partition table. Then boot from USB (EFI CloudReady), used "cgpt create /dev/sda" and installed. --> OK

    Before reboot, i applied the "EFI-quirk".

    4) Now try booting - get anywhere?

    IT WORKS !!! 10 seconds to get the login screen ! Thank you very much, i realy appreciate the time you took to help me !

    I'll talk of your solution at work, i'm working in IT for a company that migrates to chromebooks. I think it can be a good solution to re-use 2/3 years old computers.

    1
    Comment actions Permalink
  • Forrest Smith

    :-D 

     

    Glad it worked! Sad that Samsung made such a bad BIOS that needs these workaround, but I'm impressed by your perseverance.

     

    Hope this thread can become a memorial for future users having this kind of issue.

    0
    Comment actions Permalink
  • Jake Ellingson

    I've been working on an install with an ASUS laptop and this finally did the trick!
    Thanks!

    0
    Comment actions Permalink
  • Marc

     Hi Jake, glad to see that my solved problem is helpful !

    0
    Comment actions Permalink

Please sign in to leave a comment.