USB on Acer Chromebook C720P, Acer Iconia W700, Macbook Air mid-2011

Comments

7 comments

  • Bill Grau

    I found out that in order for Terminal shell to work, these need to be executed: Loading extra module: /usr/share/crosh/removable.d/50-crosh.sh Loading extra module: /usr/share/crosh/dev.d/50-crosh.sh On Chromebook Acer C720P with cloudready, they don't... suggest fix

    https://twitter.com/inabster/status/1011052495068717056

    0
    Comment actions Permalink
  • Forrest Smith

    Hi,

    We don't officially work on Chromebook compatibility at this point - that could have to do with the issues you're running into with shell/tty access .

    That said, I am surprised to hear that your not able to open a shell.
    When you press ctrl+alt+t do you see a crosh shell prompt? Or does nothing happen at all?

    Further - any chance our using the Education or Enterprise Edition downloaded from my.neverware.com ? These versions don't support cmd line access of any kind, of that might explain the issue.

    0
    Comment actions Permalink
  • Bill Grau

    I am usng the Home free version - 

    The crosh shell prompt I get, it's typing shell that gives an error.

    This does not happen in the liveusb.

    I wouldn't mind getting the cloudready working off a SSD, but the command line install I am using after typing

    sudo chromeos-install --dst /dev/sdc

    gives the error message -
    initctl: Unknown instance: 
    This will install from '/dev/sdb' to '/dev/sdc'.
    This will erase all data at this destination: /dev/sdc
    Are you sure (y/N)? y
    32+0 records in
    32+0 records out
    16384 bytes (16 kB, 16 KiB) copied, 0.00315485 s, 5.2 MB/s
    33+0 records in
    33+0 records out
    16896 bytes (17 kB, 16 KiB) copied, 0.00139922 s, 12.1 MB/s
    WARNING: Primary GPT header is invalid
    ERROR: Entry outside of valid region
    ERROR: -i 16 -l STATE -b 14864450 -s 110180940 -t EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

     

    0
    Comment actions Permalink
  • Bill Grau

    I tried the following two suggestions to get the command line installer working (none solved it)

    1. fix it by editing /opt/neverware/cgpt_reader_guy.py and just hard-coding the return value for def get_last_free_block(lines). The value you should use can be found by running cgpt show /dev/sda -d and finding the value for "Last LBA".

    2. Dirty fix:

    • "mount -o remount,rw /" # re-mount "/" as rewrite
    • "vim /opt/neverware/cgpt_reader_guy.py" # edit the file
    • change the line that says "target_drive = disk_util.choose_destination_device_path()" (towards the end!) to "target_drive = '/dev/sdX'" (where "/dev/sdX" is the drive you want to install to)
    • re-run the installer, again providing the --dst "/dev/sdX"

    from

    https://neverware.zendesk.com/hc/en-us/community/posts/212448327-Installation-not-working

    0
    Comment actions Permalink
  • Bill Grau

    SOLVED - for Acer Iconia W700 - I used an external SSD with USB 3.0 adapter & installed via command line an older version of cloudready r44 (for newest versions v60+ cmd line install does not work) then let it upgrade to latest OS. - might work with ctrl-L on Acer CB C720P -

    Details on my tweeter feed.

    https://twitter.com/inabster/status/1011493902677835776

    Side Note - reason this works is because v44 (probably also all up to v50+) have no bug for using the command line to install.

    v60+ have a bug that needs to be fixed, unless it is intentional by Google to bork the chromeos-install to discourage installation to USB, it wouldn't surprise me.

    0
    Comment actions Permalink
  • Bill Grau

    Acer Chromebook C720P booting from USB solved, the USB created installation using Acer Iconia W700 works on C720P with shell working,

    so it's a matter on how it is installed, installing it directly internally to C720P internal SSD creates problems.

    The trick was to install cloudready r44 first to a USB SSD that is seen as a fixed disk drive (not for removable USB sticks) - then allow it to upgrade to r60+ ...

    Fix cmd line install for r60+ if you can...

    0
    Comment actions Permalink
  • Bill Grau

    Your version r68 broke the ability to boot from usb on Acer Chromebook C720P - 

    Of course you will reply that you do not support Chromebooks, still a shame.

    Also not supporting Android is another shame.

    But you are owned by Google, it figures...

    0
    Comment actions Permalink

Please sign in to leave a comment.