Running CR on Samsung Chromebook 550

Comments

9 comments

  • Sennic

    Are there any special installation requirements?  I tried the same on my Samsung S550 and it didn't seem to work. 

    It would be great to get an up to date OS on the machine, it still has plenty of life, I would be grateful for any help

     

    0
    Comment actions Permalink
  • Mong Xeng Khan

    I used the regular install method (https://guide.neverware.com/install-cloudready/) when I had to reinstall CR version 70 due to some buggy update (Samsung 550 is not a supported hardware after all) a few months back. Not sure if there's any changes for the latest version. 

    0
    Comment actions Permalink
  • Sennic

    Hmm...sorry if my question is obvious but do you have to go into developer mode and "recover" the chromebook from the USB drive? 

    The instructions seem to be for Windows laptops etc. I've installed dual boot linux on windows but the locked down nature of Chromebooks is new to me.  Plugging in the USB doesn't do anything on my chromebook, it just opens the folders.  Unless perhaps I didn't create the USB correctly.

    Again, I'd be grateful for tips, the S550 has good specs and going to waste at present!

    0
    Comment actions Permalink
  • Mong Xeng Khan

    Yea, you'll need to siwitch to Developer Mode and allow boot from USB.

    Some information is here: https://www.chromium.org/chromium-os/developer-information-for-chrome-os-devices/samsung-sandy-bridge

    The command to enable USB boot may have changed over the years, so if the instructions above don't work, you'll need to find an up to date instructions or try different commands.

    0
    Comment actions Permalink
  • Sennic

    Great I found my way through with these, and trial and error. Seems to work pretty well and I'm delighted to have my Chromebook working again (Google dropped support at ChromeOS 65). It was probably over-specc'd (4gb RAM etc) so still works well.

    In case useful to anyone else, here were the steps on my Samsung S550 Chromebook. You need to create the CloudReady USB, then...

    1. Put chromebook into developer mode
    2. Switch on, Ctrl + d to get rid of the scary screen, but don't log in at the screen
    3. Press Ctrl + Alt + ->
    4. You now get the black screen, type 'chronos' and hit return
    5. There are some helpful instructions on the screen by this time (might be different on another chromebook). Type the following command:
    sudo enable_dev_usb_boot
    I got a message to say "SUCCESS: Booting from any self-signed kernel from SSD/USB/ SD Card slot is enabled"
    6. Switch off (I think, can't quite recall!)
    7. Insert your CloudReady USB
    8. Switch on, press Ctrl + U ('u' instead of 'd' means the chromebook boots from the USB)
    9. CloudReady starts. To install it, don't log in, click on tray at the bottom right, install is one of the options in the dialogue box.
    10. Let it install and it should shut down (may restart)
    11. You can remove USB, switch on and press CTRL + d

    My S550 is useful again, Neverware should publicise this!

    2
    Comment actions Permalink
  • Sarah Evaravenspell

    I am attempting this. CR is currently being installed. Just wondering tho, did you disable dev mode after CR Is installed or just leave it as it is?

    0
    Comment actions Permalink
  • Sennic

    Just leave it in dev mode, so whenever you startup you get the unhappy computer screen and need to press ctrl+d.  The only issue I've had is updates seem to break the install and you have to start again, ie switch off developer mode, re-install a genuine Chrome OS, then go through the above process again.  Bit of a pain, if anyone has ideas how to fix the update issue I'd be grateful!

    0
    Comment actions Permalink
  • Sarah Evaravenspell

    I am happy with my install. It should be fine leaving it on Dev mode. How were your updates so far? Im just glad that everything is working :D except for the bluetooth. I cannot seem to turn it on..~

    0
    Comment actions Permalink
  • Sennic

    I fixed the issue with updates (where it tries to update but just freezes) but it required a bit more work.  To get CloudReady updates that work you need to replace the original Google firmware on the S550 with a new BIOS system.  And to do that you have to overcome a physical write-protect restriction on the motherboard, so you have to open up the laptop case.  This isn’t a doddle on the S550 but it wasn’t as difficult as I thought it would be. Total job took about an hour. And the outcome is that the S550 and CloudReady are working better than before - the touchpad had become laggy and glitchy and now seems perfect.  

    I’ve tried to note the steps I took below. I’m no tech guru so some of the descriptions may not be technically correct and there are probably better ways of doing it. But then they may be understandable to non-tech people :D

    If you want to try this - always remember this could brick your chromebook so that it won’t work.  Be sure you want to risk it and can live with your machine not working ever again, you are doing this at your own risk. I thought it was worth the risk because I have other laptops, I have a bit of self-taught experience messing around with computer innards, and using old versions of browsers and operating systems is a risk as well.  

    So there are basically 2 steps

    1. Disable write-protect on the motherboard temporarily.  To do this you have to make an electrical connection across a small white jumper on the motherboard.  
    2. Install a new BIOS.  This step is easier than the first, especially if you are familiar with terminals in linux, using chronos etc. 

    Firstly some background.  This link has some useful pictures and info about taking the cover off the S550:

    https://www.chromium.org/chromium-os/developer-information-for-chrome-os-devices/samsung-sandy-bridge

    There is a thumbnail on this page that, if you click on it, opens to a full page picture with labels showing where various bits are, including the write-protect jumper (more of this later).  There is also info about developer mode and other useful stuff

    So if you want to go ahead, here are the steps.

    1. Your S550 needs to be in developer mode. There are instructions in the link above. 

    2. You need to let the S550 boot up and reset itself into develop mode.  Let this complete then switch off. 

    3. Important step before going further is disconnecting the battery. Make sure you have a charger ready as once done it won’t start on battery, you need the charger to get it going afterwards. Make sure the charger isn’t plugged into the S550.  Gently push the end of a paperclip into the small hole on the underside of the S550 near the screw at the front/middle until you hear a click. If you’ve done this right, when you try to switch it on, nothing should happen.

    4. Disable the write-protect. I used the instructions at this link but I only followed these to step 5:
      https://ar.al/2018/12/31/sometimes-you-have-to-stick-a-screwdriver-in-it/
      The method is a bit “Heath Robinson” - he uses a screwdriver to make an electrical connection across the jumper, there must be better ways so take care - but it worked for me. 

    5. With your connection in the jumper in place, put the S550 cover back on (you might want to avoid putting every screw etc back in right now until sure it has worked) then plug in the S550 and switch on.

    6. Connect to the internet

    7. No need to log in, press ctrl + alt + ->

    8. Type “chronos”

    9. Then I followed the instructions here at Mr Chromebox to install the new BIOS:

      https://mrchromebox.tech/#fwscript

      As long as you type the script correctly it works well. It detects what type of machine you have and installs the new BIOS.  Follow the instructions (I think the option I chose was [3] but basically there was only one which you could use, the ones which wouldn’t work are greyed out/disabled).  It also gives you an opportunity to create a backup of the original firmware on a USB - not a bad thing to do.

    10. When completed, you S550 will boot differently.  It opens up with a splash screen showing a white hare on a black background. 

    11. I found it helpful to press escape at the boot screen and go into and change the boot order so USB was the first option.  This might be necessary, I don’t recall.

    12. Save changes to boot device order, then switch off the S550 by holding down the power button.

    13. Now is probably a good time to carefully remove the temporary electrical connection across the jumper and fix the cover back on permanently. 

    14. Plug in the CloudReady USB and switch on the S550.  (You could of course install a different operating system - a light linux distro, or GalliumOS which is aimed at Chromebooks, though I haven't used that). 

    15. CloudReady starts. I changed the keyboard layout to English UK at this point, you may have another preferred keyboard layout.

    16. To install CloudReady, don't log in, click on the tray at the bottom right, “Install OS” is one of the options in the dialogue box

    17. Let it install to the hard drive and it should shut down

    I used the method above and CloudReady has since successfully updated to a newer version. And as I said earlier, the S550 is working better than it did with my previous CloudReady install. The mousepad is smoother. Happy days!

    0
    Comment actions Permalink

Please sign in to leave a comment.