Android Studio keeps going into setup wizard

Comments

11 comments

  • Srikanth Reddy

    Can someone please help me on this?

  • Forrest Smith

    Hi Srikanth,

    Sorry to say that I just don't know what the issue might be here. I think I understand the problem you're having, but I'm not sure how Android Studio wants to save state or why that might be failing.

    You could try removing the flatpak and reinstalling to see if that helps? 

    You could also try enabling crostini and installing Android Studio via that. 


    Overall, though, keep in mind that these are early and experimental features for us. There may simply be bugs.

  • Srikanth Reddy

    Hello Smith,

    Thanks for the reply.

     

    I already tried removing and reinstalling Flatpak. Unfortunately, it didn't work.

     

    I think I can try the Crostini route. But I don't know how stable Crostini is in current release (68.4.59). Moreover, I am not sure if the Crostini support works along with "Shell" and "Flatpak" supported provided by CloudReady.

     

    Please suggest.

     

  • Forrest Smith

    Crostini will work in a separate terminal (it is running inside a container) but should provide you full cmd line access and UI integration for running Linux applications.

    You may need to do a little coordinating for where your files are - there are separate locations for the Chrome OS Downloads folder and the default save location for files inside the Crostini container. You can drag files back and forth inside the Files App once you have Crostini enabled. 

  • Srikanth Reddy

    Tried in multiple ways,

    Took a while to even get the "Terminal" app appear in the app drawer.

    Once I click the icon, it's stuck at "Starting container inside Termina VM". Tried disabling and re-enabling the flag multiple times, but with no luck.

    Am I doing something wrong?

  • Forrest Smith

    Hi Srikanth,

     

    The Crostini setup is, as listed there, not fully stable and especially not compatible with all hardware. Your device might not support it (for now, anyway).

     

    I would encourage you to reboot and try again, and to make sure your BIOS has all virtualization and VM/VT-x settnigs enabled. 

  • Srikanth Reddy

    Hello Smith,

    It looks like it was my mistake; not sure though. Crostini is working now.

    This time I initiated the install and left it alone at the "Starting container inside Termina VM" message. After a long time (Not sure how long), it entered the Terminal command prompt.

    May be I didn't give it enough time before, and prematurely assumed it was stuck.

     

    "sudo apt upgrade" works, "sudo apt install" works.

     

    Yet to test GUI applications. Have some doubts regards the performance.

    Would a bulky Flatpak application that runs directly on Chrome OS perform better than a relatively slim Crostini application that runs out of a container?

    Do you recomend installing a Flatpak, when available, over installing through Crostini?

     

    Thank you for the help.

     

  • Forrest Smith

    Hi,

     

    Flatpaks are a better bet (for now) anytime performance is of concern. The Crostini setup is a container inside a VM and it has no sound or hardware acceleration, so graphics (and performance in general) may be a problem.

    Flatpaks are native to the system, so while they may not have perfect performance across the board, they should be hardware accelerated and generally reflect the capabilities of your device.

     

    If you want to be able to flexibly interact with the application from the cmd line and have a set up that is as similar as possible to traditional Linux, use Crostini. If performance or sound is important, use a flatpak where available. If those two needs conflict... good luck ;-)

  • Srikanth Reddy

    Thanks for the help Forrest,

    I tried out a few GUI applications from Crostini, but there seem to be a lot of issues.

    Unfortunately, Android Studio didn't work there either. It installed fine, but once I start the application and try to interact with it in any way, it simply crashes the whole system.

     

    So, now I've gone back to a fresh Cloudready install. Making use of Docker and Flatpaks (Most of the Flatpak apps I need are working fine except Android Studio). For Android Studio, I have decided I will use a VM.

  • Forrest Smith

    Awesome. Glad you've got a decent workflow going.

     

    Our team internally saw your recent tweets - thanks for the positive words and for sharing. Keep it up!.

  • Jak Mit

    Hi i have very simmilar problem with inteliji I had installed it through flatpak and it restart configuration every time, another problem is that when I try to establish sdk to java  i can not find it although I installed java through crostini and sudo apt install openjdk-8-jdk - but ia can not find location of it, maybe i am blind but I can not , would be very glad for help!

     

Please sign in to leave a comment.