Dell Inspiron 15 R Track pad not working

Comments

10 comments

  • Forrest Smith

    Hi Fasil,

     

    Can you try these steps to see if the touchpad comes back?

     

    1) First, switch to a TTY console by pressing "ctrl+alt+f2" (if that doesn't work try "ctrl+alt+fn+f2"). If this works, it should land you at a black and white console login screen. You don't need to do anything there - just press "ctrl+alt+f1" (if that doesn't work try "ctrl+alt+fn+f1") to switch back to the full UI.

     

    2) Put the device to sleep for a minute or two, then wake it back up.

     

    3) If you're comfortable with command line stuff: Try various steps described here:  https://neverware.zendesk.com/hc/en-us/articles/360000665207

     

    Do any of those help?

    0
    Comment actions Permalink
  • Fasil

    Thank you Forrest Smith.

    I tried them and sorry that it didn't solved the issue.

    I couldn't understand that it is working while booting from usb and not working when booted from hard drive.

    The 4th section in the article matches with the case, but those steps didn't resolved the issue

    0
    Comment actions Permalink
  • Forrest Smith

    Fasil,

     

    I am also not sure why it would work while livebooting but not elsewhere.

    Does the keyboard perhaps have a fn key combo to disable the trackpad that's been accidentally triggered? 

    Can you confirm that, if you liveboot a CloudReady USB, the touchpad still works?

    0
    Comment actions Permalink
  • Alexanderjamesklein

    Literally the same problem here but with an older Dell Inspiron 14 - occasionally the synaptics driver is loaded and the touchpad fires up, but 90% of the time requires external input. Live initially worked fine, but after install when I boot to live USB it also retains the issue, 

     

    I have been unable to execute the steps listed in other posts as most of the time the synaptics driver isn't listed. Next time it pops up I will report my log data. 

    0
    Comment actions Permalink
  • Mikoto San

    Hi there.

     

    Have you tried going into the BIOS, and see If you have any trackpad settings?

    On some devices, you should be able to set it to "basic" which In most cases solves the problem :)

    -Mikoto

    0
    Comment actions Permalink
  • Alexanderjamesklein

    I updated the bios last night on the Inspiron but unfortunately found that it didn't offer any additional settings concerning the trackpad. This is after I hunted & followed all of the steps that the awesome super hero Forrest Smith  has recommended personally as well as curated in these forums. Literally, have had my OCD triggered, but now that I've tried this device with lubuntu, ubuntu, other chromium builds as well as bliss OS I am feeling like this touchpad isn't playing nice with the current linux kernel. 

     

    Dell Hotkeys could be an issue too as I see them appear on evtest, but other than I guess wiping the drive I don't understand how live boot saw the drivers for this bugger then upon install we lost them, and then also don't understand how I never see synaptics drivers appear on evtest. I've only seen the trackpad resurface twice, and this hasn't occured since I dusted off my copy-pasta terminal skillz otherwise i'd dump some logs. (lol.) 

     

    I even imported the deprecated 50conf files that are no longer in use, as referenced in the arnold the bat site. 

     

     

     

    0
    Comment actions Permalink
  • philbo daddins

    hey @Mikoto San  Can you please send me the Tutorial to get android apps running on Coudready? I tried to access your comments but it's gone and comments disables - can send me a link daddins@gmail.com

     

    Thanks

    1
    Comment actions Permalink
  • Martin Gonzalez

    Hey philbo or Mikoto can I get the link as well? my email is tightoto@gmail.com thanks in advance 

    0
    Comment actions Permalink
  • abhinav gupta

    hi bro can you guide me that how i enable playstore in chromium os

     

    if you are using whatsapp my number is 9643778981

    my email id is abhinavgupta21500@gmail.com

    0
    Comment actions Permalink
  • Rachel Samuels

    Has anyone found a solution to the touchpad issue? I have a Dell Inspiron 15-5566, and I have the same issue as the OP--the touchpad worked fine when running Cloudready from USB, but is not working with Cloudready installed to the hard-drive (it did at first, but then stopped and won't come back). 

    0
    Comment actions Permalink

Please sign in to leave a comment.