Asus C300M Chromebook Usb boot



  • C. Nero

    Answering my own question. 


    The above procedure worked for running CloudReady v68 from usb on Asus C300M Chromebook (64bit).  On the initial screen (when debug mode is enabled) hit ctl-u to boot from the usb disk.  ctl-d will take the normal path as before to the original internal Chrome OS.  

  • C. Nero

    There is a problem in the crosh behavior (started with c-a-t) of CloudReady v68.3.26 booted from usb on the ASUS C300M Chromebook (64bit).  Both show identical info for chrome://version.

    From chromebook crosh>

    I enter shell, there is no shell command.   

    Background:  I have been running the same version on my Lenovo 11e (win10 machine) again booted from its usb disk (the two separate usb disks for each machine started with the same identical CloudReady HomeEdition v68).   Also I have been running many version of HomeEdition for the last 1.5+ years, and using shell and root access all the time.

    In comparing the initial shell output in the opening crosh screen, I see,

    1. Both have the first identical Loading extra module:

    Loading extra module: /usr/share/crosh/removable.d/

    2. but  the Chromebook cross did not have the following second line of the windows notebook.

    Loading extra module: /usr/share/crosh/dev.d/


    Any suggestions how I may be able to get the shell?  I have seen another post in the forum, that he was missing that extra module too...


  • C. Nero

    I saw another thread here discussing a similar problem.   I think the initial boot configuration is not correctly detecting that it is a ubs boot.  Or it detects that (because the removable/ is loaded), but it does not load the dev.d/ for security of the chromebook internal sw.  However my chromebook itself is configured to be in dev mode, confirmed by the Verify off initial screen.

    Me thinks, the boot script does not take the second needed step of checking when the host is a Chromebook, that it is indeed in dev mode to enable the dev.d/ shell; or the checking for dev mode of parent is failing!!


    In any case I do not mind turning verify off on the usb boot image, however I think I need to do that from the booted shell of the CloudReady booted from the usb.  Right?  Here lies a chicken and egg problem.  I cannot get into the shell to disable verity !!!   Is there a way to do this, for the time being in this v68?

    If you need clarifications, I am eager to supply any needed info.

  • C. Nero



    FYI, this is the other thread I referred to above

  • Forrest Smith

    Hi Nero,


    I'm not sure I can help here. Using CloudReady on Chromebook hardware is smiply not supported. I imagine this issue is related to our use of rootfs verification on builds that are not properly verified by Google.


    You may be able to get to a shell by pressing ctl+alt+f2 (or equivalent) and then logging in as chronos.

Please sign in to leave a comment.