[SOLVED] Trackpad is moving! but dont click :(

Comments

6 comments

  • Luizcf14

    News!, I solve this problem changing few parameters on 40-touchpad-cmt.conf file.

    Before:

    Section "InputClass"
    Identifier "CMT for Synaptics Touchpad"
    MatchUSBID "06cb:*"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    # default calibration values for Synaptics firmware
    Option "Pressure Calibration Offset" "-51.1766"
    Option "Pressure Calibration Slope" "1.7716"
    EndSection

     After: 

    Section "InputClass"
    Identifier "CMT for Synaptics Touchpad"
    MatchUSBID "3602:*"
    Driver "synaptic"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    # default calibration values for Synaptics firmware
    Option "Tap Minimal Pressure" "0.1"
    Option "Pressure Calibration Offset" "-51.1766"
    Option "Pressure Calibration Slope" "1.7716"
    EndSection
  • Forrest Smith

    Great to see it worked! You'll need to re-do this change after each update, fyi.

     

    For future readers - note that the changes made to the 

    MatchUSBID

    line will not work for all devices - your need to identify the USBID for your particular touchpad and use that.

  • Luizcf14

    Mr. Forrest Smith, Thanks for the information.

    Is there any way to point this modification to another file that is not overwritten when updating?

  • Forrest Smith

    Sorry - in order to maintain the other benefits of the Chromium OS update system, we can't provide that kind of permanent system edit.

     

    You can probably make the change easier tho - try adding your USBID to different entries in /etc/gesture/50-neverware.conf instead. That should be more quickly editable at least.

  • lucaswotta

    My trackpad is the same as yours, but it is not working. Can you tell me how you did it? I can’t find a solution that works.

  • Luizcf14

    Hello @lucaswotta,

    Could you send you 40-touchpad-cmt.conf ?

    And print you "evtest" command menu-list?

     

     

Please sign in to leave a comment.