CloudReady 70.3 Broke WiFi

Comments

26 comments

  • Official comment
    Forrest Smith

    Hi all,

     

    Please try these steps to workaround the issue on v70.3:


    1) Log in

    2) Press ctl+alt+t to open a terminal

    3) Type in "shell" and hit enter

    4) Confirm that the yellow "crosh" prompt is now a green "chronos@localhost" prompt

    5) run sudo disable_verity 

    6) run sudo reboot

    7) repeat steps 1 > 4

    8) run sudo mount -o rw,remount /

    9) run sudo rm /lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin

    10) run sudo rm /lib/firmware/ath10k/QCA9377/hw1.0/notice_ath10k_firmware-6.txt 

    11) run sudo reboot

    12) Log in and attempt to reset / enable wifi

    Comment actions Permalink
  • Joe

    What model is the laptop/adapter

    0
    Comment actions Permalink
  • Ren

    It's an ASUS-VivoBook-E12-E203NAH

    0
    Comment actions Permalink
  • Joe

    Hmm ASUS now just built-ins everything. Would you know the wifi part/adapter (in windows go into device management) and you should see the wireless adapter tab. Other than that go back to 68 and disable updates until a new build comes up or just wait for a Administrator to look into it

    0
    Comment actions Permalink
  • CL

    Same exact thing happened to me with a Lenovo ideapad 110s. Wifi worked perfectly before update but wouldn't switch on for 70.3. Tried to disable/enable in BIOs to no avail so reverted back to older version. (Love updated UI though, so excited for a fix!)

    Would like to add that 70.3 update fixed the same problem that an Acer Aspire was suffering from however.  

    0
    Comment actions Permalink
  • Forrest Smith

    Hey all,

    We really appreciate your feedback.

    CL - can you send logs from both devices? I'm interested in looking into precisely the wifi hardware that was fixed, and the one that broke, in the upgrade.

    We can't promise any support for uncertified devices , but if possible we'll aim to find the regression and keep as many components working as possible.

    0
    Comment actions Permalink
  • Derick Mozes

    Hi everyone,

     

     I had the same problem with an Acer Swift 1 SF114-31-P4ZQ - I found that the installed Wi-Fi module is a Wi-Fi chip (QCA9377) from Qualcomm. It worked perfectly before 70.3. I had to buy a USB wifi adapter in order to make it work again. I then found this topic and tried Forrest Smith's feedback, which solved the situation.

     Thank you for the support!

    0
    Comment actions Permalink
  • Ren

    Thanks working again :)

    0
    Comment actions Permalink
  • Jeremy Tan

    Thanks for the update and the solution provided here.

    Worked for me on my Asus TP203N..

    0
    Comment actions Permalink
  • Galo J. Guevara

    Joe,

    You mentioned a valid option as a backup plan, if all else fails when trying to get back wifi after the version 70.3 update. That is to downgrade back to version 68.4. How exactly do you do that? Where can I find the 68.4 install version?

    Also, my two kids have identical budget laptops (grandma got them last Christmas): Lenovo Ideapad 120S-11iap

    They initially came installed with Win10, but were so slow and basically useless. The kids stop using them after about 2 months. But about 7 months ago Cloudready put the life back into them. Kids have been using them daily ever since (besides - they both are familiar with Chromebooks at school).

    Anyways, one of the laptops took the version 70.3.34 update and the wifi stopped working. When you tried to toggle the wifi switch to the "ON" position, it just toggle's itself back to the "OFF" position immediately. The other laptop happened to be turned off (dead battery). When it was recharged again it was still on version 68.4.59 and was working just fine. But the next day it also took the update and stopped working, just like the other laptop.

    Anyways..., the solution Forrest Smith gave worked for both of them. Thanks a whole lot (my kids are happy again).

    Just please, please, please...., next time you (Cloudready) do an update - Don't Break Anything. Please!!!! Otherwise my kids will throw a fit - and Grandma too =)

    0
    Comment actions Permalink
  • Joe

    Galo J. Guevara, apparently Neverware stopped releasing the builds after 56.3 as far as I know so I'm unable to help as far as that goes. Maybe a Administrator knows a way to get later builds

    0
    Comment actions Permalink
  • Say Young Lee

    I had same problem, and downloaded new version, deleted old version. I found now the solution here.

    As I cannot log in for finishing install, what can I do without wifi?

    My laptop is Lenovo ideapad 120s.

     

    Please help me.

     

    0
    Comment actions Permalink
  • Forrest Smith

    Say - 

    You can press ctrl+alt+f2 at the login screen to go through the steps above prior to logging in.

    0
    Comment actions Permalink
  • Say Young Lee

    Thank you! But the install process was in initial stage and keep showing connect to network page. It is new setting up and I already reset the OS. As I have no ID and PW, I don't have log in page yet.

    0
    Comment actions Permalink
  • Forrest Smith

    Sorry - to clarify, even before the network page, if you press ctrl+alt+f2 (or in some machines ctrl+alt+fn+f2) you should reach a console.

    0
    Comment actions Permalink
  • Say Young Lee

    second one worked. I can see the black screen and need to log in. which id and pw was needed for log in? I cannot use the capslk for writing qw. Thank you so much.

     

    0
    Comment actions Permalink
  • Say Young Lee

    I put the chronos in ID and found way. Thanks!

    1
    Comment actions Permalink
  • Say Young Lee

    I still have trouble

    1) making chronos pw? I wonder if I don't have to make pw for sudo command

    2) without pw, I got the green prompt but 8,9,10 command does not work.

    0
    Comment actions Permalink
  • Say Young Lee

    after 9, I got this message

    rm: cannot remove ' /lib/firmware/ath10k/qca9377/hw1.0/firmware-6.bin' : no such file or directory

    Is that as I didn't put capital PCA? I cannot use capital letter in that mode.

    Please advise me.

    0
    Comment actions Permalink
  • Say Young Lee

    Maybe the Capital letter issue. I found the way!! And it is working. Thank you so much.

     

    1
    Comment actions Permalink
  • BlackSheepTxRx

    Thank you very much Forrest Smith  this worked perfectly!

    0
    Comment actions Permalink
  • Dennis Skinner

    Acer Aspire R3 with new ChromeOS install.  Same wifi chip.  Same issue.  Removing firmware 6 resolved it.  Thanks!

    0
    Comment actions Permalink
  • Forrest Smith

    Quick update - we expect to have a fix for this in v70.4. If you have this issue, and find that you need to repeat the workaround after the next update, please let us know so we can refine the fix.

    0
    Comment actions Permalink
  • Dave G

    Thanks Forrest.  When can we expect to see v70.4 available?  70.3 was my first installation so I don't have anything to go back to...

    I also have not been unable to try the workaround - ctrl alt f2 brings up a black screen, no prompt.  I can ctrl alt f1 back to the welcome screen, but really nowhere to go from there without wifi.

    Hardware is Lenovo 110S.

    0
    Comment actions Permalink
  • Dave G

    sorry for my typo -- I have not been able to try the workaround...

    0
    Comment actions Permalink
  • Forrest Smith

    Dave -

     

    There's a big with crashing we're seeing on a small subset of models that's holding up 70.4 right now. When that is resolved, we will ship 70.4 immediately.

     

    If you're unable to get to a console you could try a USB ethernet or wifi connection to get you logged in. That's the best option for the time being. Even if you don't have a dongle, a USB connection to a smartphone should allow you to briefly tether (again, via USB instead of bluetooth or wifi). It won;t eat much data to log in, and then you can un-tether once logged in and proceed with the workaround from there.

    0
    Comment actions Permalink

Please sign in to leave a comment.