Linux (Beta) / Crostini Installation Failed, Terminal Crashes and Uninstalling Linux (Beta) also fails

Comments

49 comments

  • Wayne Eymann

    I too have exactly the same problems.

  • Edward L. DeBuhr

    I as well have this issue with the latest version of the 64 bit. I am running a Dell Latitude 3490. Would be nice to have this as could run CLI commands to extract IBM DSA reports.

  • Forrest Smith

    Hi all,

     

    Ca you guys try with a fresh install of v70.4 ? I'm not confident, but I think this should work if you reinstall with latest.

  • Wayne Eymann

    I am running 70.4 64 bit and no go.

  • Edward L. DeBuhr

    No go on same level on Lenovo Ideapad S10-3.

    Just created the new USB key last night too. So latest level of CR.

     

    If you can, is it possible to list the steps necessary to make this work? Or is it just click to enable and hope for the best?

    Thanks for the help on everything

    Ed

  • Forrest Smith

    Edward,

     

    I believe your S10-3's hardware is, unfortunately, not going to support these features. An Atom chip of that age has little or no virtualization support.

     

    For those of you using newer devices, make sure all virtualization settings are enabled in your settings and try again, and consider trying again on a fresh install of v70.4 . If you continue to see issues, please reply here with more info about your particular hardware model name/number, cpu/gpu, etc.

    We expect improvements in v71.1 , but there's no way to be sure what will work or not so we'd like to collect as much info as possible.

  • Wayne Eymann

    HP Pavilion 500-223W I3 processor 4 gig ram. Virtualization enabled in BIOS. Still no go on Linux Beta.

  • DR

    Dear Forrest,

    I have the same issue on Linux Beta installation failed and after reboot no possible to see nothing. (I have to use tty to login and then return to X desktop, then removed linux installation to reboot and all under control now.

    Linux Beta doesn't work for me. Hardware Asus F302 Intel I7 Ulv + hd integrated grafic Intel Card plus nvida dedicate (optimus switch).

    Version is 64 bit Cloudreay OS 70.4.39.

    I have also checked bios option enabling  VKM and also flagged in Chrome://flags  experimental crostini ui.

    I have some bugs also in flatpack at least not all; thnderbird telegram desktop shotwell filezilla and other works fine only libre office freeze the system and i can see only border of the compositor window.

    Again thanks for Your effort this system is amazing, only a question even if both function (Flatpack and Linux Beta Container) have to be considered experimental-unsupported wich of this will evolve in standard solution, crostini or Flatpack? I 'm asking only due now i quite prefere flatpack due no VM and direct acces to hardware resources.

    Thank You

    Duccio

  • Forrest Smith

    DR,

     

    Have you tried disabing NVIDIA/Optimus so that the device will use only Intel? That may meaningfully improve reliability.

  • DR

    Thank You I'll try to disable in bios if possible i have to check.
    So at least what you suggest Flatpacknor crostini?
    Thank you again

  • Forrest Smith

    I would recommend using Crostini whenever you don't need high-performance or sound. It's more secure and more flexible. 

    If you need gpu acceleration or sound, try a Flatpak.

  • Edward L. DeBuhr

    Forrest,

    No go on the Dell Latitude 3490 using the beta.

    I am going to wait for a future release to see if it fixes it. Currently for what I need linux I will use crouton.

  • Michael Pobega

    For what it's worth I have a Thinkpad X1 Carbon Gen 3 that cannot install Crostini on 70.4, but can install it on a d71 developer build. I haven't taken the time to dive in to figure out exactly why it fails in d70, but I would definitely check back in the future to see if the support improves. It's possible that Google is just expanding the feature to more processors.

  • Maksim Lin

    I see same thing as Michael on my ThinkPad Gen2 X1 Carbon. 70.4 Cristiano does not install correctly, moved to dev channel (71) with a fresh cloudready and Crostini all works fine.

  • Forrest Smith

    Glad you're seeing improvements in v71!

    We'll hope to keep breakages and regressions like this to a minimum in the future. In the mean time, anyone having issues should check out our beta/dev channel for v71 to see if that works better!

  • Luke Blevins

    I tested Cloudready 70.4 on my AMD A6-3420M APU based laptop, and flatpaks did not load, nor did Virtualbox or Crostini. I will test out version 71 on the dev channel and report back here.

    Keep up the great work

  • Luke Blevins

    Okay, on version 71, it looks like Flatpaks work now, also including Virtualbox. However, crostini displays a "Failed to mount Linux Files" message.

  • Forrest Smith

    Luke,

     

    You may want to disable/remove Crostini and then re-enable it to see if the behavior is any better. Similar, you might want to do a fresh install of v70.4, upgrade to v71 without installing Crostini, and then enable it for the first time on v71.

  • Zahid Rangel

    Forrest,

     

    Hey, hope you are doing well! I have an HP Folio 9470m, it's an i7 3rd generation (I believe) with 8 gigs of ram, do you think it will be supported to run Flatpaks/Crostini? I've had some trouble getting Linux to install and uninstall and although the icon for the terminal appears in the app drawer when I click on it, it just loads for 30 seconds and then disappears.

    Thanks in advance!  

  • Forrest Smith

    HI Zahid,

     

    I haven't tested any similar device, but note that, as mentioned above, v70 has some issues which are resolved in v71.

     Have you updated via the dev channel to v71.1 yet and retried everything?

  • Pindar

    Hi there,

    Linux Beta is also not running on my Macbook Air (Mid 2010).

    In 72.2.26 (Developer Build - neverware) developer-build chromeover64 neither a clean install of Linux nor removing the failed installations works. 

    The CPU is capable of VM, but don't know if a bios setting needs to be changed too.

    Cheers

    Pindar

  • Forrest Smith

    Pindar

    A 2010 MBAir is pretty old for this feature - I'm not confident that virtualization is supported in general on that device. Even if it is in principle, keep in mind that Google designed this feature for use on Chromebooks made in the last 2-3 years, so a 9 year old chipset seems pretty likely to hit issues.
    Keep trying after new updates, as I'm optimistic it will function more stably over time, but even in the long run I don't think we're targeting devices of that age-range for this.

  • Pindar

    @Forrest Smith
    Thanks for your fast reply. Fair enough. I'm gonna do that. However, I'm really happy with the perfomance of Cloudready on my "Methusalem notebook" (although needed to upgrade to a SSD).

    BTW Could I use flatpacks without Linux Beta?

  • Forrest Smith

    Sure, flatpaks are supported on CloudReady even without Linux - should work for your machine.

  • Pindar

    Works like a charm!

     

  • Zahid Rangel

    Hi Forrest,

     

    It's Zahid again, I figured I would wait until the new Cloud Ready update came out to see if Linux would work this time. I just updated my HP Elitebook Folio 9470, however, the option to install Linux in the settings has now disappeared. I tried following your Experimental Crostini Support article/tutorial you posted but I still cannot get the terminal to appear on my app drawer either.

    ( https://neverware.zendesk.com/hc/en-us/articles/360001737547-Experimental-Crostini-Support-64bit-Home-Edition- )

    I would greatly appreciate any advice! 

    Thank you! 

  • DR

    I have just updated Cloudready 64bit home edition to V. 72

    I have immediatley tryed to switch on Crostini Linux Beta.

    At the secons tentative now it works I have installed Thunderbird and all works and is also possible to Pin Linux app on dock and maximize-minimize it.

    This eveing I try again but it seems all ok. This evening I'll try again only a strange thing APT seems very slow, thunderbitd installation so long..

     

  • Forrest Smith

    Hi Zahid,

     

    Those instructions may need to be updated - right now, on v72, you should be able to run Crostini on a 64bit CloudReady image without enabling any special flags, but just by opening the settings menu :

     

     

    Are you sure you're using 64bit? Make sure your version in "About CloudReady" reads "72.3.32" - anything else would not be our latest stable and might not even show that settings item.

    If you still don't see it, I'd recommend reinstalling 72.3.32 and starting fresh.

  • Zahid Rangel

    Forrest,

     

    Thank you so much for replying.

     

    I do have 64bit and I am running the latest Cloud Ready version  72.3.32 however the Linux option has disappeared.

    I mean my computer has a i7 3rd generation with 8 gigs of ram, I'm sure it should be more than capable of running Linux.

     

    Thanks!

  • Forrest Smith

    Is virtualization enabled in your BIOS? Before you reinstall, if recommend making double sure if that.

Please sign in to leave a comment.