widevine is missing

Comments

10 comments

  • Geofrey Hill

    Widevine is no longer supported on 32bit. Google, the creators of widevine no longer support the fetaure so we are no longer able to include it.

    If you would like to use Widevine you will need to use the 64bit version.

    2
    Comment actions Permalink
  • Pau Rodriguez

    There are an update of Widevine 32bits, current 32bits CloudReady 72.4.33 aren't shipping it so you can update it using this procedure (thanks to ruario gist):

    1. Enter terminal: Control+Alt+T
    2. Enter to advanced shell: shell
    3. Disable verity (if not already done): sudo disable_verity && sudo reboot
    4. Remount with write permissions: sudo mount -o remount,rw /
    5. Download and run the ruario script: curl https://gist.githubusercontent.com/ruario/3c873d43eb20553d5014bd4d29fe37f1/raw/f9b15356baae5dae0e1fd5c591d56bb20d4fd195/latest-widevine.sh | sh
    6. Reboot: sudo reboot

    Google don't update quite often this Widivine repository so don't rely much from it.

    Maybe Neverware could implement an update button for Widevine like the flash plugin, so that one can update it without disabling verity. But anyway, they plan to stop supporting 32bits on August'19...

    Update: This workarround works with 32bits CloudReady 74.3.14. I don't undestand why Neverware still not shipping it with the latest Widivine library.

    2
    Comment actions Permalink
  • emdoublyu

    Hi Paul, I tried the above steps, but I receive the following errors:

    1.

    sudo: disable_verify: command not found

    2.

    mount: cannot remount /dev/dm-0 read-write, is write protected

    3.

    Please enter your root password so Widevine can be copied into place

    su: must be run from a terminal

    __________

    I run Cloudready v72.4.33 (32bit) on an HP Mini 2140 which has only 32bit hardware and cannot run 64 bit OS

    Any ideas or tipps how I could get Widevine 32bit enabled and loaded to Cloudready 72.4.33 32bit?

    Thanks in advance for any help.

    0
    Comment actions Permalink
  • Pau Rodriguez

    Follow the official linked steps there for disable_verity.

    Here I attach the link again:
    https://neverware.zendesk.com/hc/en-us/articles/360001343908-Disabling-RootFS-Verification

    I did copied it with a typo, now fixed.

    0
    Comment actions Permalink
  • Forrest Smith

    the command is 

    "sudo disable_verity" - verity with a "t" not an "f"

    0
    Comment actions Permalink
  • emdoublyu

    Hi Pau, hi Forrest, thanks very much for your hints.

    Switching to shell and prompt turn into green"chronos@localhost". OK.

    The command:
    sudo disable_verify
    does bring the error:
    sudo: disable_verify: command not found

    I run Cloudready v72.4.33 (32bit) on an HP Mini 2140 which has only 32bit hardware and cannot run 64 bit OS.

    Any other idea maybe?

    0
    Comment actions Permalink
  • Pau Rodriguez

    emdoublyu check spelling corrections Forrest Smith bring up in the above comment.

    0
    Comment actions Permalink
  • emdoublyu

    @Pau: LOL - sorry I was misunderstanding "verify vs. verity" in the first.

    Okay, so here is where it stops now:

     

     

    after this step the package 1.4.9.1088-linux-ia32.zip gets downloaded and saved.

    next info I get is:

     Archive: 1.4.9.1088-linux-ia32.zip

    inflating: libwidevinecdm.so

    Please enter your root password so Widevine can be copied into place.

    su: must be run from a terminal

    ___________________________________

    So my next question is:

    • at what stage I would be able to provide the root password?
    • and what is the "root password" for cloudready?

     

     

    0
    Comment actions Permalink
  • Pau Rodriguez

    For your questions there are other posts like this one:

    https://neverware.zendesk.com/hc/en-us/community/posts/206835307-Root-Administrator-password

     

    0
    Comment actions Permalink
  • Tracy Earl

    @emdoublyu

    Do "sudo su" before running the script. Worked for me!

    0
    Comment actions Permalink

Please sign in to leave a comment.