Display Resolution unable to change

Comments

10 comments

  • Geofrey Hill

    Can we please get some more details so we can look into this?

    Are you using v72?

    If so, did you see it at time of update form v70? or after some use on v72?

    Are you using 32bit or 64bit?

    Is CloudReady installed on your device or are you livebooting?

    Are you connecting to your TV with HDMI? If so, are you using any adapters (ex. DVI to HDMI)

  • Tony Stark

    I am on v72

    I installed with a v70 usb drive and updated to 72 hoping the display would work right

    I am 64bit

    cloudready is installed to drive

    I am connecting with displayport to hdmi cable (computer only has vga and display port so I bought that cable)

  • Tony Stark

    I am just curious how to fix it because I lived booted a linux distro and was able to adjust the resolution just fine. Would you know how I could fix it? Is there a configuration file that I could adjust? I know when chromium was using xorg, you could just change the x11 conf file. Is there such a file with the freon display backend?

  • Forrest Smith

    There's not cmd line interface or config file that I know of for the non-X display management stack - sorry.


    You should definitely update to v72.4 where we have continued to make some minor graphics refinements  - those could feasibly help in this case.

     

    The other things that would be useful to know are:

    • If you use VGA out, does this issue come up?
    • If you disconnect and reconnect your displayport cable from the monitor multiple times, does anything change?
    • If you connect via displayport to a different tv or monitor, does the resolution match?
    • If you put the device to sleep and wake it back up again, does the resolution fix itself?
    • Does the Display settings show more, or different, options after a sleep resume cycle?
    • Repeat the above two questions, but replace sleep/resume cycle with a switch to console (ctrl+alt+f2) and then back (ctrl+alt+f1). (note that you might have to add in the fn key in both of those cmds).
    • What kind of GPU is in HP desktop? If you're unsure, please send us logs using alt+shift+i (preferably send those logs from v72.4 while the problem is exhibiting, and include the URL to this forum thread in your description for our reference)
  • Tony Stark

    OK so I tried what you recommended about trying VGA to see if it changed anything and no it didn't. I am not sure if it is necessarily a bug, but a lack of video control. The GPU is the intel graphics 2000. I even updated to 72.4 on the unstable branch and that didn't change anything.

  • Forrest Smith

    Hi again Tony,

     

    Can you send logs from the device while its exhibiting the issue? We'd like to confirm the graphics in your device from those logs and take a look at any other errors.

  • Parid Kushta

    Hi Forrest,

    I second the issue to a similar HP Elite 8200 with a Core i5-2400 and 8 GB of RAM, paired to an NVidia GeForce GT 610, HDMI to HDMI to a 4K Philips TV. Version 72.4 Stable/Beta.

    I have no control over the resolution at all. No audio in HDMI or on-board speaker either. Any ideas?

    Thank you for your huge help, i've read countless of your replies to other people. 

  • Forrest Smith

    There are probably two issues there.

     

    1) Nvidia HDMI output may not support audio over HDMI on our OS - it's an unusual case for our paid customers, so we've never been able to prioritize. Cmd line "sudo alsamixer" might give you some options to experiment with this, but I can't walk you through it or guarantee it'll even work.

     

    2) Resolution may be a bug we're zeroing in on. Does you device have more than one display output port? If so, please try an experiment for me:

    * Boot up with one display output attached to your monitor, as normal

    * Confirm the resolution isn't mapping properly, as previously described

    * While logged in, switch from the initial display output port to (one of) the device's other port(s).

    * Check if resolution can be controlled on that one properly

    * Switch back to confirm the initial port is still broken

    * Repeat all of the above, but switch which port you start with

     

    In some recent testing, we found that this bug came up only on the monitor connected during initial startup, not on any secondary monitors. This won't be a great workaround for you, but knowing that it is the same behavior on your HP Elite 8200 would help us confirm that this issue (which we're seeing on a Lenovo M700) is not model-specific.

  • Parid Kushta

    I am sad to notify that i do not have another way of connecting, like VGA or DVI or DP, my monitors (both Philips TV's, one 4K and one 768p) only have HDMI. So i am unable to try your method. I tried removing and reinserting the HDMI cable while logged in, but that didn't do the work.

    It is unfortunate news to not yet support NVidia cards, nor AMD for that matter (tried with an AMD one too, same result.). NVidia cards are everywhere so it would make sense to support audio through hdmi of a PCIE card.

    Hope we get some updates on that front, thank you.

  • Forrest Smith

    On v73.1 you may see improved support for AMD - you can update to v73.1 using the dev release channel or by reinstalling with this image:

    https://davrt8itj6cgg.cloudfront.net/cloudready-free-73.1.66-64-bit/cloudready-free-73.1.66-64-bit.zip

Please sign in to leave a comment.