Uninstaller: Is there an Uninstaller to assist a user revert to a clean PC

Comments

4 comments

  • Forrest Smith

    here are our instructions for formatting your USB installer:

    https://neverware.zendesk.com/hc/en-us/articles/216226067-How-do-I-format-my-CloudReady-USB-installer-

    As for your internal drive:
    Other OS install procedures should provide tools for either overwriting the entire disk during install, or to clear those 27 CloudReady partitions one at a time in order to reclaim the space.

    You can also find dozens of other methods out there for completely wiping a drive that are free.

    One final note- I don't believe Windows or macOS provide dedicated *uninstaller* utilities. can you link to the programs you're referring to?

  • Joe

    Sadly the only way to uninstall / wipe the drive you'll need to either A: create a Linux Distro of Linux MINT to erase the Drive or B: Search for "Wipe Drive" on CR forums and the first topic it'll show you how but for some it'll be hard and C: by a Windows Setup via CMD you can clear "AKA wipe" the drive through DiskPart

  • SirRon

    "One final note- I don't believe Windows or macOS provide dedicated *uninstaller* utilities. can you link to the programs you're referring to::

    To Forrest:  I not sure what you mean, but If your specifically referring that OS's 'do no have uninstallers then let me clarify.  Whether it be an OS or application; be it purchased, trial or free, in order to use it there has to be a setup/installer for this software to be used.  It is also practical that it should have an uninstaller and some OS's like some Linux Distros and  alternate Android OS's that allow testing from a USB stick or installing to a hard drive would have a tool I guess written by the developer to uninstall the OS.  For the OS during the setup could have a disk partitioning utility to delete and create partitions before installing but some may not.I may have to fetch a free one as suggested.  It may be assumed by the developer that the drive is prepared to be sent to a target location, be it as a folder within your current OS or a free partition. Some may include removing themselves from a boot manager.  I don't recall ever seeing so many partitions on a drive as I did with Cloud Ready.

    I've tried using an imaging software like AOMEI Backupper to restore an image of the entire drive after the incident with Vector Linux (I posted that issue on the community forum here) and still could not boot.  When I checked the disk status, it still had 27 partitions.  I tried using Windows 7 Installation CD.  It could not see any partitions (the 27 of them). Options were just disabled.  Not even clicking on INSTALL NOW for Windows could continue. It knew something was wrong but could not do anything.

    To Joe: I did not see an option to do a task to wipe the disk in Windows or command prompt. I am not familiar with a command to do so or an AKA Wipe, what ever this means. Sorry guys but to do long procedures to delete 27 partitions or search for tools on the web to do this job, although I am sure investing all that time can be done, it would is not practical for a newbie/customer to do.

    With all the difficulty I just described with familiar partitioning tools from paid OS's, what I am saying is that from the start as good as CloudReady is, it should have a tool, uninstaller or what ever, that simply by starting the software that will remove all the partitions do it in one pass. I am sure for security purposes how CloudReady works with this must be a trade secret of sorts but not having this ability to return equipment back to normal is almost like my equipment has been bricked or hijacked by CloudReady.

    If I could not overwrite the entire drive with an image or have Windows setup CD and disk partition tool within it see and delete it, I would not prefer the long method.  We need a tool supplied by Neverware to do the removal of the partitions since it does not ask us to create it when installing CloudReady.

     

  • Michael Pobega

    I just want to chime in here -- in general there is no such thing as an operating system "uninstaller". Generally to "uninstall" an OS you just install another in it's place, wiping the hard drive in the process.

    Installing Linux over Cloudready is no problem; I've done it countless times and the Ubuntu/Fedora/Debian installer ISOs have all wiped CloudReady properly out of the box with no manual steps necessary.

    The problem with the Windows installer is that it doesn't have a "wipe disk" option like most other OS installers do and that's a Microsoft problem, not a Neverware problem. There is an option for advanced users to do it via the shell (see instructions here: https://www.tenforums.com/installation-upgrade/74539-delete-format-partition-during-clean-install-windows.html ), but that is something that frankly shouldn't be expected of users and I'm personally still surprised a disk wipe isn't available every time I do a Windows install. Even so, you could just delete every partition one at a time using the partitioning tool available in the installer, it only takes about three minutes.

    Another option available to you is to liveboot CloudReady and wipe your drive using the command line (using the `dd` command, or parted/fdisk/cfdisk to simply blow away the partition table.)

    As for the USB, I've never had a problem reformatting on Windows. The only problem is that Windows enumerates the partitions as different connected drives (E:/, F:/, etc) so when you format those you are only formatting the one partition. You would need to use something like device manager or a disk format utility to fully format the device. Again, this isn't a fault with CloudReady's partition scheme, it's a fault with how Microsoft enumerates partitions as 'drives' and tries to hide the idea of a 'disk drive' away from the end user.

    Alternatively as Forrest mentioned you could wipe the whole USB using the Chromebook recovery utility, then use Windows tools to create a partition.

    Providing an 'uninstaller' is just not feasible, especially since multiple solutions exist that already do what you're requesting.

    (Also, it sounds like you took a partition backup with your backup tool rather than a full-disk backup, which may be the issue with your restore not working)

    Sorry for the late reply, I just wanted to clear some misinformation here in case anyone comes across this in a Google search!

    Take care

Please sign in to leave a comment.