"Failed to install runtime"

Comments

29 comments

  • Forrest Smith

    Are you running 32bit or 64bit CloudReady?

    And what flatpak did you attempt to install?

  • tom56

    Hi

    I'm running the latest 64 bit.

    I tried to install kodi, vlc and gimp.

    Every time, same error message.

  • Forrest Smith

    Hi Tom,
    Have you tried reinstalling CloudReady?

  • tom56

    Hi

     

    I re-installed CloudReady.

    Error when launching vitual machine (linux installation) and same message "failed to install runtime" ... :(

     

  • Forrest Smith

    Hi tom,

     

    That's too bad - sorry! What kind of hardware are you working from? Do you have any others to compare on?

    And are you livebooting USB or fully installed?

  • tom56

    Hi

     

    I'm using a toshiba satellite i5 with AMD Radeon graphics.

    I fully installed on the laptop.

    Too bad yes, the os turns really good except this linux trouble.

  • Forrest Smith

    I thiiink it's likely that the radeon graphics are the problem in this case. If you have the option, you might want to try disabling them in favor of Intel-only graphics. (Many, though not all, devices that mix Intel and AMD will allow you to configure this in BIOS).

     

    You can also try using Linux apps via the Crostini set up if you enable virtualization support in your BIOS - have you tried this? It also has hit-or-miss compatibility at this point, but could run the same apps and then some (albeit with lower somewhat performance) compared to Flatpaks.

  • tom56

    Thanks for answer. I'll try this solution, disabling radeon for intel-only and let you know.

  • tom56

    Hi again

     

    in BIOS, I can't find settings to disable radeon graphics... :(

  • Forrest Smith

    It may not be an option - if so, you might need to just enable virtualization and try linux apps via Crostini instead.

  • Svetoslav Stoilov

    hi there im having the same issue,im with thinkpad x220 with intel video

    pls help

  • Forrest Smith

    Hi Svetoslav 

     

    Is this error occurring for all flatpaks? Or just one?

    Also, as suggested above, have you tried reinstalling to see if that helps?

  • Svetoslav Stoilov

    Hi the error occurred to all flatpaks..connot install none of them.

    Dont want to reinstall, the system is 1 hour old...

  • Svetoslav Stoilov

    Damn im using Linux for a long time, at work we are using Chrome OS and i love it.

    Just installed CloudReady  on my home pc cos I saw the flatpak support and now this irritating error....so sad

     

  • Forrest Smith

    Hi Svetoslav,


    Sorry to hear you're sad. 

    Flatpaks aren't having this error for me, so it might be specific to your X220, your user profile, or your current install. I'm not sure. You can rule out each by testing (respectively) a different device, a different user profile, or a reinstall on the same device.

    I understand if you don't want to reinstall, or do any of those tests, but if you want to look into the problem, those are my recommendations.

  • Svetoslav Stoilov

    Thanks for the support Forrest.Will look for some alternatives for the apps im used to.. :(

  • noahmutsaarts
    • i no how to fix it:

      go to the terminal

      type: sudo disable_verity

      then reboot

      then go back to the terminal and type: sudo mount -o rw,remount /

      retry to install the app
       
  • Eduard Gertz

    Hi!

    I have the same problem: I tried to install flatpaks, but all gave the same error: "Failed to find runtime remote". I tried it with a live USB stick on another PC, but it had the same result. The problem is probably located on my Google account... but how I can fix it?

  • Joe

    You can't install Flatpak on a USB CR installer "it's for testing purposes only ' only by installing CR on a HDD/SSD can this go well. Other then that you can create another Google Account

  • Eduard Gertz

    O.K., I didn't know that... But the problem is still that I can't run Flatpak on the PC. And creating another account would mean that I can't use my "regular" Gmail etc. So, that's a bad option.

  • Forrest Smith

    Eduard,

    Have you tried multiple different flatpaks? Do they all fail the same?

    And have you tried a reinstall?

  • Eduard Gertz

    Hi Forrest!

    I tried both options: I tried to install 4-5 flatpaks and reinstalled the whole system... but that didn't change anything.

  • Forrest Smith

    Are you on v74.4? If not, I recommend updating and trying again.

    If you are already, maybe try out v75 in this unstable preview:

    https://go.neverware.com/previewrelease

  • tom56

    Hi,

     

    what would change using v75 ?

    I also have a Zotac with ion nvidia graphics, I could not install any flatpak, same problem than toshiba with radeon graphics... :(

  • gschofie

    Using an X220 as well and seems to be a permissions issue as noahmutsaarts hinted above. Steps taken

    • Tried to install flatpak from website - error 'failed to find runtime remote'
    • Ctl + Alt + T to drop to terminal - then 'shell'
    • CD /home/user/xxxx/Downloads
    • 'flatpak install org.vim.Vim.flatpakref'
    • error open(O_TMPFILE): Permission denied
    • 'sudo flatpak install org.vim.Vim.flatpakref'
    • error: mkdir (/root/.local): Read-only file system

    Tried the steps that noahmutsaarts outlined, successfully disabled verify, but unable to remount 

    • mount: /: cannot remount /dev/dm-0 read-write, is write-protected.

    So, definitely a permissions thing, not sure what to try next

  • gschofie

    Sorted and working!! Steps taken

    • Redid 'disable_verity' then 'sudo reboot'. Voila 'verity disabled'. 
    • sudo mount -o rw,remount /
    • Then tried to install flatpak - FAILED
    • Back to terminal
    • $ sudo flatpak install org.vim.Vim.flatpakref

    At this point you are asked if you want to do install the repo. I just said Y to all and Voila! Can now install any flatpak from flathub.org. 

  • gschofie

    Set this up now on other X220, same issue, same fix, but found a shortcut

    1. Drop to shell and disable_verity

    2. Sudo_reboot

    3. Sudo mount -o rw,remount /

    4. Follow the instructions for Chrome OS at flatpak.org

     

     

  • Eduard Gertz

    Hi!

    Yeah, thanks for the shell tip- for me, it worked.

    Thanks to all of you! You are a great community, at it's fantastic to interact with you (:

    Eduard

  • Matthias Dekker

    I have the same problems with that write protected thing

Please sign in to leave a comment.