Install WiFi-drivers

Comments

8 comments

  • Forrest Smith

    This might be possible on CloudReady but to help I'd need some more detail. Can you go through the process on CloudReady once more and take screen shots along the way of the cmds and any output they create?

  • Isaac

    So when booted to the usb, I can't turn on WiFi, it turns off by itself. I press ctrl + alt + F2 to get to terminal. Then I login as chronos and I tried first to follow these steps: https://neverware.zendesk.com/hc/en-us/community/posts/360020839593 

    But there's no /firmware-6.bin on the latest cloudready, the path is sudo rm /lib/firmware/ath10k/QCA9377/hw1.0/board-2.bin or board.bin.

    Then I tried to do the WiFi settings I do in Linux cp /sys/firmware/efi/efivars/nvram-* /lib/firmware/brcm/brcmfmac43340-sdio.txt

    But there's no nvram folder in /efivars.

    So the last thing I tried was following this: https://neverware.zendesk.com/hc/en-us/community/posts/115000946148-HowTo-get-Broadcom-802-11abgn-Wireless-SDIO-Adapter-to-work 

    So I just: cp * /lib/firmware/brcm

    and then: sudo rmmod brcmfmac
    sudo modprobe brcmfmac

    But still no success, WiFi is not working.

  • Forrest Smith

    It might be the case that CloudReady can't find/access the nvram firmware file you're looking for. If that's the case, you can liveboot another Linux distro that can see it, like Ubuntu, and copy that firmware file to a separate external storage device (like a normal USB device or an SD card).

    You can then use that file, from the same external storage, instead of grabbing it from the nvram path, on CloudReady following otherwise the same steps as you were originally trying to follow (mostly as you do in Linux).

  • Isaac

    I did disable verity and then rebooted. But now I realized that maybe I have to install cloudready to the hard drive so that those settings remain?

    I grabbed the brcm firmware from Linux and I put it inside /lib/firmware/brcm folder in cloudready USB. Should I put it somewhere else maybe? Or if I install cloudready, then load the firmware from a USB like you said, where should I copy the firmware to?

    Thanks for helping!

  • Forrest Smith

    I believe you'll need to
    1) reimage your usb
    2) install to internal disk
    3) make your changes
    4) re-make the changes after each update

    Note that I still can't guarantee that the wireless will work in the end, so if the risk of installing CloudReady to your internal drives and then later having its WiFi still not work, you may want to halt here.

  • Isaac

    Wow! Finally, I got it to work!

    I reimaged my USB and installed cloudready to my internal disk. Afterwards, I disabled verity and rebooted. But still, I couldn't get the WiFi to work! I saw that the drivers I need already existed in the /lib/firmware/brcm/ path, but I couldn't find the nvram path, so something was missing there.

    So I followed this guide for debian linux on the T100HA: https://wiki.debian.org/InstallingDebianOn/Asus/T100HA 

    and it says: mount -t efivarfs efivarfs /sys/firmware/efi/efivars

    So I mounted those paths and Voila! I could find the nvram path. So I just did what I used to do in Linux: 

    cp /sys/firmware/efi/efivars/nvram-* /lib/firmware/brcm/brcmfmac43340-sdio.txt
    modprobe -r brcmfmac
    modprobe brcmfmac

    and WiFi now works and I can use the laptop.

  • Isaac

    Only problems now is: 

    1. Brightness: I can't adjust it and I don't know how to fix that, if I can change display drivers somehow.

    2. Audio: not working! Same here with missing drivers I think.

    3. Mouse: two fingers scrolling. I had that problem in some linux distros to, it was only in Fedora I got that to work

    4. Sleep: I don't think my laptop really sleeps, but it never worked in Linux too so.

    Otherwise I really like this! More fast and stable than linux.

Please sign in to leave a comment.