Skype Now gives this error message "Device not supported"

Comments

14 comments

  • Forrest Smith

    The latest Skype for Web changes do not support Chrome OS (or CloudReady, or Linux), as a matter of Microsoft's policy:

    https://betanews.com/2019/03/08/new-skype-for-web/

     

    You can try to work around the issue with this info:

    https://chromeunboxed.com/skype-for-web-update-working-chromebook-broken-fix/

  • Bidwell Ely

    Forrest, what I was hoping for is instructions from "the mothership" on how to get to Skype working again. This is a Cloud-ready Inc. issue. As Sveta Ro wrote in Russian and he is absolutely right. Here is the English translation:

    Skype no longer works in the browser and this button opens an error page. Applications from Google Play are not supported by the system, so we are left without Skype.

    Skype is widely used by enterprise and schools as well as home users.

  • Forrest Smith

    Maybe I'm misunderstanding you, but it seems pretty clear current that this is not an issue specific to CloudReady - Chrome OS and Linux also do not support Skype's new web client, as per the first link I shared.

    The workaround I passed in my second link is the best alternative for Skype's web functionality that I know of currently. This was a change by Microsoft, and unfortunately they don't consult Neverware before making changes - very rude of them, but sadly true.

    Since we're a small company that'd depends on our business and education customers to fund our efforts, we are *always* eager to understand the needs and use cases of organizations that want to use the paid version of CloudReady managed on 100s or 1000s of devices - that feedback from those customers is how we direct our engineering effort. Please don't hesitate to reach out to our sales team (sales@neverware.com) with your organization's name and the quantity of devices to let them know about your needs. They will be sure to connect me or one of our other Product Managers with you to understand what the options might be to support Skype on CloudReady in your environment.

  • Bidwell Ely

    Unfortunately or perhaps, fortunately, I am a home user. I will try the second link and see if I am up to your expertise. I realize you are a small company and am thankful that you respond to my worries. I have been using my CloudReady computer to Skype with my friends weekly. Now I will not have that option (unless the fix works). 

    My note was really to alert your company of an impending problem. Is there a way of updating the Chrome Browser besides going to Google Play? Perhaps that would be a workaround.

    Thanks again for your responses.

  • Bidwell Ely
    Thanks, Forrest for your patience.
    I have found the solution to the Skype issue was a lot easier than I anticipated. You add an extension called User-Agent. I tried it on my CloudReady book and it worked like a charm.
    Click on the link to the Agent User.  In options, you click on MS Edge. That lets you use MS Edge to launch Skype.
     
  • nangtienngu

    This is not Cloudready's fault as this issue is affecting all Linux distros including Google Chrome OS.

  • Forrest Smith

    The link to Google Play Store is not because a browser update will fix this - it is to refer you to the Skype Android app as a alternative to the web version. This won't work, as Android apps don't run on CloudReady.

    You could try downloading and using the Skype flatpak (assuming your device is on 64bit CloudReady) and see if that works
    https://flathub.org/apps/details/com.skype.Client
    But note that flatpak can be buggy on CloudReady and are considered experimental and unsupported.

    Ultimately, if Microsoft follows their recent patterns, they'll eventually support Chrome OS on the new Skype web client. It may just take some time.

  • Bidwell Ely

    Forrest, As I said in my previous note,

    I have found the solution to the Skype issue was a lot easier than I anticipated. You add an extension called User-Agent. I tried it on my CloudReady book and it worked like a charm.
     
     
    Click on the link to the Agent User.  In options, you click on MS Edge. That lets you use MS Edge to launch Skype.
    I found today that the Agent User turns the Chrome Browser into an Edge Browser (although it does not change the Google screen) not just for Skype but also for Gmail and other business. And of course, Google sends out messages about using their browser, which is why I assumed that I am now running Edge.
  • Bidwell Ely

    Forrest, I have been using the Agent User for a couple of days now. Skype works great. I have Agent User set for MS Edge on Windows. The curious item is that even though I see the same Google Browser Screen, I am getting messages about downloading Chrome Browser on the browser screen. That makes me think that Edge is now the browser. Is this a correct assumption? There has been no change in my bookmarks though.

    Thanks

     

     

  • Forrest Smith

    You are still using CloudReady and the Chromium browser. Changing your user agent just changes what name the browser provides to websites when they ask what kind of browser is being used.

     

    Any site that gives you a message about downloading the Chrome browser is being told, by your User Agent extension, that you are using Edge even though you are not.

     

    You could selectively enable and disable the User Agent switcher so that it is only on while you use Skype if you want to avoid those messages.

  • Nolan Darilek

    Hey, having a slightly related issue. I've changed my user-agent, tried both Chrome on Windows 10 and Edge. Despite getting to the Skype web app, trying to make calls to the echo test server tells me that audio/video calls aren't supported. More accurately, the button is disabled.

     

    This used to work fine. I also just did a web RTC echo test and that works, as does Zoom.

     

    Anyhow, I don't really *need* Skype at the moment, and recognize this is Microsoft's fault. Just wondering if anyone has thoughts on why calls might be disabled? Proprietary plugins are up-to-date. Flash isn't installed, but I'm trying that now, not that I expect it to make a difference.

     

    Thanks for any help.

  • Forrest Smith

    I can't speak to why you might be seeing it fail even though you followed the workaround steps - we have internal and external users who've confirmed the workaround, so maybe Flash support is going to turn out to be the key for you?


    You might also want to remove your User Agent changer and then re-add it, starting over in the steps, in case something important got missed. 

  • Nolan Darilek

    Thanks for letting me know that many users have confirmed the fix. One thing I wasn't clear on is whether the folks who wrote the blog posts actually tested a call, or if they just managed to access the app.

     

    I looked at my browser console and saw a bunch of blocked requests. I'm behind a Pihole and running Ublock Origin, so I'll try disabling both. If that works, I'll whitelist some holes through one or both.

  • Bidwell Ely

    Nolan, I am the user that wrote the original note. I am not an employee of CloudReady.

    I tested the call and had another Chrome OS user change User Agent and Skype with me. It worked like a charm.

    I follow Forrest because he has very good, clear and useful answers. So once again, THANK YOU, Forrest, of your ongoing contributions, to this site.

Please sign in to leave a comment.