Science Channel video not playing

Comments

23 comments

  • Forrest Smith

    HI Tony - 

     

    That won't play for me on v73.1 either.

     

    couple questions:

    * Have you tried it on earlier versions of CloudReady?

    * Was your Google CHrome test (on another OS) on v73? or on a stable v72 version?

    * Does the page look only partially-loaded for you? Does your javascript console show this error?

    0
    Comment actions Permalink
  • Tony Baloney

    This is the first time I've tried it, was heading to bed when I discovered I JUST MISSED a good episode so I was checking to see if I could stream it on my trusty cloudready macbook. NOT!

    Works on Google Chrome v73(stable) on Manjaro Linux.

    Works on Waterfox 56.8.1 on Os x Lion & Manjaro Linux.

    ......& my console is IDENTICAL!!!!!!!!!!

    0
    Comment actions Permalink
  • Tony Baloney

    ...DRM seems fine here!

    0
    Comment actions Permalink
  • Tony Baloney

    THIS could be HANDY for you guys!!!!!!!!

    0
    Comment actions Permalink
  • Forrest Smith

    Thanks for the added details.

     

    If the issue is limited to just this site, I would assume it isn't a DRM issue. The console output suggests there's an issue, potentially somewhere in the bootstrap module they're importing?

    Anyway, any additional examples of this failure on other sites would help build the case for it to get attention. If it's only sciencechannel.com streaming that's broken, and it isn't newly broken on v73 compared to v72 (which we're planning to check out), then you should assume it may take a while to get addressed by our team.

    0
    Comment actions Permalink
  • Tony Baloney

    ..There are plenty of fish in the sea!!!! (full of plastic)

    0
    Comment actions Permalink
  • Tony Baloney

    Looks like it's all the channels in the Discovery family....?????

    0
    Comment actions Permalink
  • Tony Baloney

    ...Is that enough to escalate the problem @Forrest???

    0
    Comment actions Permalink
  • Forrest Smith

    I can't say for sure, but I'll certainly document it.

    1
    Comment actions Permalink
  • Tony Baloney

    Fails on v72 also....does that make it worse or not???

    0
    Comment actions Permalink
  • Forrest Smith

    Our system prioritizes new issues. Issues that exist on earlier versions indicate that the user base has a high tolerance for the issue (or isn't seeing it at all).

    0
    Comment actions Permalink
  • Tony Baloney

    ...I thought it was a done deal with streaming videos with the v72 progress announcement....guess not.

    0
    Comment actions Permalink
  • Bidwell Ely

    This is interesting, on v73, with user-agent on, I had to log-in with to my cable provider. After the login, the Science Channel worked like a charm. 

    0
    Comment actions Permalink
  • Tony Baloney

    User agent is a work around for a bug!

    0
    Comment actions Permalink
  • Forrest Smith

    To be clear, the User Agent switcher is generally not  a work around for a bug.

    If a site is checking User Agent strings to confirm that a product is compatible, they sometimes block browsers that are perfectly capable, technically, of playing the videos. We use a Chrome UA string to avoid scenarios like this, but some UA checkers are pickier in ways we can't anticipate.

    Ultimately, like with the new restrictions to Skype online, it's restrictions being proactively enforced by the provider, not a bug in CloudReady, that leads to this kind of scenario.

    Good to know the UA workaround can help here though - @Bidwell - can you share with us which UA strings work vs don't?

    0
    Comment actions Permalink
  • Bidwell Ely

    On the Science Channel, without User Agent on, there was just the background and a few shows suggested. With the User Agent on (set to Microsoft Edge on Windows) which is the setting suggested for Skype, the screen changed to a multitude of show suggestions. 

    I have not tried other sites which might be doing the same drill. I went to the science channel on the sneaking suspicion that when code is written for one site as big as Skype there might be other sites using Microsoft web software. I have noted that Chrome Browser asks me to download it even though I am using CloudReady with the Chrome Browser as Forrest mentioned to me, Therefore Chrome is picking up the User Agent data as well.

     

     

    0
    Comment actions Permalink
  • Tony Baloney

    Chrome/Linux:

    (Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.27 Safari/537.36)

    works too, but not the Chrome/ChromiumOS options.

    0
    Comment actions Permalink
  • Tony Baloney

    ...I can't get maxgo to work under any user agent. Maybe because it's http & not https???

    0
    Comment actions Permalink
  • Tony Baloney

    ...& I'm getting a report from a chromebook owner (daughter) that sciencechannel.com doesn't work.

    0
    Comment actions Permalink
  • Bidwell Ely

    Here are the links I used at Forrest's suggestion. 

    https://chromeunboxed.com/skype-for-web-update-working-chromebook-broken-fix/

    https://chrome.google.com/webstore/detail/user-agent-switcher/clddifkhlkcojbojppdojfeeikdkgiae?hl=en

    I will say that once you load the extension, you will need to set it for Microsoft Edge on Windows, and click on "Remember last used User-Agent at startup".

    As I said earlier, once the User-Agent is set up in Chrome Browser, there is a change with the Science Channel as well as Skype.

    0
    Comment actions Permalink
  • Tony Baloney

    Your first link indicates that this is also a Chromebook issue too!!

    0
    Comment actions Permalink
  • Bidwell Ely

    It is not the Chrome OS that is the issue. It is the Browser. That is why you will see the same issue on both the CloudReady and Chrome books.

    Tony, install the Browser extension User-Agent in the Chromebook's Chrome Browser and set it to Microsoft Edge on Windows,  and you will be able to Skype and use the Science channel.

    For me being cut off from Skype was the biggest issue. I am retired and do not travel. Not being able to talk to my friends, who live in various parts of the world, on a weekly basis, put me in a lather. Fortunately, Forrest saved the day. I shared the User-Agent with one of my friends who had been unable to Skype on his Chrome Book recently due to Chrome issues. Once he installed User-Agent he came across perfectly. Such a relief for both of us.

    1
    Comment actions Permalink
  • Tony Baloney

    ...it's the platform....chrome on linux works...so not the browser.

    0
    Comment actions Permalink

Please sign in to leave a comment.