Operation System not found

Comments

16 comments

  • Forrest Smith

    Hi grant,

     

    Does your USB installer work any differently on any other hardware? (you don't have to install, just test if it boots)

  • Grant Matthew Nelson

    Hi Forrest,

    Well, I just tried it on an HP laptop and it booted just fine.

    Now what?

  • Forrest Smith

    One possibility is that the Nvidia GPU in your laptop is just not compatible with CloudReady. You can look for graphics/GPU/Nvidia/Optimus settings in your BIOS to try to work around this, aiming to disabling discrete/switchable/Nvidia graphics and force use of Intel graphics if there's any setting(s) to that end.

     

    Its also possible that you're seeing an issue with UEFI vs. Legacy boot modes. You might find that your device boots better if you reset your BIOS settings prior to install, or if you change the boot option you're selecting while booting.

  • Joe

    In BIOS be sure Secure Boot is Disabled and CSM is Disabled and.... That Sata UEFI is Selected

  • Grant Matthew Nelson

    SATA options are ATA and AHCI. Was set to AHCI, changed to ATA - no difference.

    No options for setting the GPU.

    No joy. Am I just out of luck?

  • Joe

    As Forrest said that the GPU is probably incompatible with CR. You'll have to look at the Blogs for info. On new releases and just recreate a USB and just test

  • Grant Matthew Nelson

    Okay.

    Thanks!

  • Forrest Smith

    Grant,

     

    Worth reiterating that an error like yours ("Operating System not found") could be a result of mixed up UEFI/Legacy (or other boot mode) settings. That error shows up when the firmware can't find anything to boot from, which, now that I'm thinking about, seems to suggest that the graphics have probably not even been engaged yet. (There could still be a graphics problem later, but right now I don't think it's even getting far enough for us to know).

     

    Have you tried resetting your BIOS to defaults prior to attempting your install? And when you're at the USB boot menu, what options do you see? And of those, which do you select when you see "Operating system not found"?

  • Grant Matthew Nelson

    Hi Forrest,

    I've reset the BIOS to the defaults.

    In the boot menu under setup, it sees the VoyagerGT USB drive. I've moved USB to the top of the boot order.

    The machine has 3 USB ports and I've tried the drive in all 3. The light on the drive flashes, so I know the system is accessing it.

    The "Operation System not found" message appears almost immediately. 

    Thanks,

    Grant

  • Forrest Smith

    1) Does your BIOS have any UEFI or boot mode settings?

    2) If you press F12 to interrupt startup do you see a one-time boot menu that you can interact with to manually select a boot device?

    2a) If so, are there options there besides just a single USB drive entry and a single HDD drive entry?

    3) Assuming the answer to #1 is "yes" - do you see any new entries or changes to the one-time boot menu in #2 when you experiment with changes to the options you found in #1?

  • Grant Matthew Nelson

    No UEFI or boot mode settings.

  • Grant Matthew Nelson

    F12 gives me these options:

    CD/DVD

    USB Storage Device (when drive is plugged in)

    Removable Drive

    Hard Drive

    eSATA

    Network

  • Forrest Smith

    Ok - my last shot in the dark - 


    When you see "operating system not found" - if you tap space bar a few times, or other keys, does anything happen?

  • Grant Matthew Nelson

    It boots into Ubuntu (current OS on the machine).

  • Forrest Smith

    OK - then I think the issue here might be that your BIOS can't/won't recognize the CloudReady OS, perhaps due to the 27 partitions. 


    You could try a BIOS update if there are any available from Dell, but that might be a pain to execute, and there's no way to know if it would actually help at all.

     

    Sorry not to have a better way forward! I hope you can find some other device to use CloudReady with some day.

  • Grant Matthew Nelson

    No BIOS updates. Bummer.

    Thanks for all the help, though. It's been a good exercise.

Please sign in to leave a comment.