Touchscreen on Lenovo D330 Detachable

Comments

8 comments

  • Forrest Smith

    Touch screens have to be recognized and driven as input devices at the kernel level - I don't think the graphics driver is likely to be a factor there.

    You could look at the logs (/var/log/messages) in AtB's built to see if you can tell what type of device the touchscreen is and how it's being recognized, including a 6 digit pid:vid. That might tell us something.

    But, unfortunately even with extra into, for CloudReady to add support for it we would need to have the hardware for ongoing testing (we don't take fixes that we can't personally test and maintain). So I think you may be out of luck for the time being, at least until CloudReady adds new firmware in our next kernel upgrade this summer.

  • Farrell Rafi

    I found the problem, in Arnold The Bat, it have the touchscreen driver which is goodix.ko (I see it on evtest). I tried to run this module in Cloudready but it print "Required key not available". In some forums it says that its because we should disable secure boot, and I have do that but it still prints that.

    goodix.ko is exist on AtB and Fyde OS build, can Cloudready provide it too?

  • Forrest Smith

    I can file a ticket for our engineering team to investigate, but note that we only build in drivers that the upstream Linux community considers safe and stable enough to mainline in the kernel. If this is an experimental driver or for some reason not included by them, it may not be something we'll be willing to ship.

     

    You mentioned that you disabled secure boot, but did you also disable verity?

    https://neverware.zendesk.com/hc/en-us/articles/360001343908-Disabling-RootFS-Verification

     

    That may be the key, and you may even need to re-mount your file system after that

    sudo mount -o rw,remount /
  • Farrell Rafi

    I already disabled roots verification. By the way, I think goodix exists in the official kernel source, take a look https://github.com/torvalds/linux/blob/master/drivers/input/touchscreen/goodix.c

  • Farrell Rafi

    Or, can you provide us to compile and insmod our own custom driver by sharing the kernel source and etcetera? Therefore neverware wont need to maintain the driver requested

  • Forrest Smith

    Hi Farrell,

    Neverware's kernel is running v4.14 and has a hybrid configuration from the cros kernel (from chromiumOS source) and upstream vanilla Linux kernel. I have been able to import drivers from other sources a number of times (for instance, getting wifi to work on a Surface Go following the instructions here), so I don't think the problem is needing to recompile the driver.

     

    Sharing source is something we're happy to do though, it just comes in a format like this (an example from a year ago):

    https://s3.amazonaws.com/neverware-cloudready-sourcedrops/neverware-2018-02-26-12.38.56-source.tar

    (We don't have the resources to develop in the open - it's not a matter of secrecy, it just takes a surprising amount of dedicated man-hours to manage a project that way.)

     

    Hopefully that info helps? 

     

    Another tip that might be worth trying is to add "module.sig_enforce=0" to the kernel cmd line boot parameters found in partition 27 in the grub.cfg file there.

  • Forrest Smith

    Another place you might make a switch:

     

    /sys/module/module/parameters/sig_enforce 

    that file has  a "Y" inside now - I dont know if you can edit it on a live system, but changing it to "N" and rebooting might allow you to load unsigned modules.

  • Eric

    Hi Farrell, A fellow D330 owner here - I have tried to install CloudReady but am not getting anywhere.

    1. Secure Boot is disabled

    2. Used USB maker and created a stick with 'cloudready-free-72.4.61-64-bit'

    3. Fn+F12 to boot from USB stick

    4..USB reads for a few seconds...blank screen...i hear some chimes on audio...blank screen....

    5. The USB stick would blink when i touch some random keys...so  its still alive...but nothing is on the display

    Any specific details your steps were different to mine? Version?

    Thanks in advance

Please sign in to leave a comment.