AMD Graphics Compatibility

Comments

25 comments

  • Forrest Smith

    Hi Pierre

    The hardware you're using isn't part of any of our certified devices, so there's no way to be sure whether/when it will work, but there are some significant improvements to AMD graphics in v73.1.

    That version is currently still unstable, but you can download and try it with this link:

    https://davrt8itj6cgg.cloudfront.net/cloudready-free-73.1.66-64-bit/cloudready-free-73.1.66-64-bit.zip

    Note that you'll need to use our Guide's "manual" instructions for creating a USB from that, and there may be plenty of bugs, even if the graphics work, since it is an unstable build.

  • 007pierre1

    When this version will be available for everyone (stable release) ?

  • Forrest Smith

    Hopefully by early-to-mid May. You can use the dev channel until that point, or install from the link above (which will update to more stable releases as they become available).

  • Randy

    Any news on this? Where would I find the dev channel for this? I also have the Matebook D Ryzen and would love to have a Chrome OS partition. 

  • 007pierre1

    The dev version (73) doesn't work. When you see the installer, the system freeze and you can't do anything.

    Also, you can't have a dedicated partition for Chrome OS. It use only the entire disk.

    I've bought a real Chromebook because there is no option to bring Chrome OS on a regular computer (or it's too complicated).

  • Randy

    Where can I find the download for V74.3? The only way I see to download it is to currently have Cloudready installed. 

     

  • Forrest Smith

    https://neverware.com/freedownload currently is serving v74.3

  • Pumpino

    I've downloaded the latest 64-bit build (74.3, and also tried the 75 preview) and tried to boot from a USB on my Ryzen 5 2400G with built-in graphics. However, I just get a blank screen. The same USB drive boots CloudReady fine on my Intel laptop.

    Is this definitely just a graphics issue, or is the processor not supported?

    If it's limited to a graphics issue, I'd consider buying a cheap graphics card, but I don't want to if the processor isn't supported.

    If I go the route of buying a cheap graphics card, are there any that are safe to go with? I was looking at an Asus or MSI 2GB GT710, since it's the cheapest that's available to me.

    EDIT: Actually, I've read that the Ryzen requires a linux kernel of 4.15 or above, and CloudReady uses 4.14, right? This might be the real issue.

  • Joe

    I would say it's more of a cpu but could also be a graphics issue as well. I have a 775 build with a GTX750TI 2GB and CR on my 16GB SD Card works great

  • Pumpino

    775 as in Intel?

  • Forrest Smith

    Hi,

     

    v75 has a 4.19 kernel, so I would think the basic graphics requirements would be met by that version.

    Did you confirm that the 75.1 preview build in particular also worked on other devices? If not, I'd encourage you to go back to that build for any continues troubleshooting.


    There may be issues with graphics in the end still, but it's hard to say what the right next step would be. Intel graphics are the most reliable options, so if you have have an Intel CPU in your machine maybe just disable/unplug all discrete gpus. If not, you may have to look at other distros for now until future improvements - we focus on the most common hardware out there, which tends to result is less support for gaming GPUs.

  • Pumpino

    I can't remember if the preview worked on my Intel laptop. I don't think it did. The stable build did.

    Do you know if CloudReady can run on an AMD CPU? Specifically, a Ryzen?

    If it can, and the issue is the graphics, well it's not possible to buy an Intel graphics card. Nvidia cards don't seem to be supported. Requiring Intel graphics basically means that an Intel CPU is required.

  • Joe

    My nVidia GTX750Ti does but I have the Intel Xeon E5450 CPU. Give it a shot man. Just buy the cheap GT710 Cards

  • Forrest Smith

    We don't have this kind of hardware to test on, so I don't know sorry.
    I'd Still encourage you to use the preview build, confirm THAT one works on your Intel device, and then try it on the AMD machine again.

  • Randy

    Huawei Matebook D Ryzen 2500u works perfectly with V75. Just created a boot disk and booted into live mode and WIFI and Bluetooth worked automatically. Touchscreen did not work, but I haven't actually installed it to the computer. 

    Also working: Function keys (Volume and Brightness, etc). Can't wait to try actual ChromeOS builds when these Ryzen Chromebooks come out. Would love to have native support for android apps. 

  • Archie

    Please how did you get the v75

  • Randy

    https://go.neverware.com/previewrelease  This will give you he newest preview release. V75.1 should be available for download on the normal page, but not 100% sure about that. Either way, just click on that link and it will automatically download the newsest preview release. 

  • Archie

    Thanks for the reply but i couldn't find the v75 on the free version it stll says v74.4.58 and i have the hp envy x360 15 with ryzen 5 2500u and vega 8 graphics and i would like to install chrome os the current v74 just keeps showing a black screen and wont even boot up the installer i tried efi>boot64.efi still black screen . Any ideas on what i can do.....i also tried the usb on an intel system and it boot fine.

  • Randy

    Hey, I'm not sure why, but that link doesn't take you to the direct download if you click on it, but it does if you copy and paste it. 

    1. Copy the text for the link I posted earlier. 

    2. Paste link and browser and hit enter. This should auto download V75.1 preview release.

    Sorry for any trouble, not sure why you can't just click it. 

  • Archie

    Oh yeah it worked. Thanks so much i will try it and give a feed back.
    Quick question: did the v75 work on your amd ryzen 5 2500u model?

  • Randy

    Sorry, was sleeping, work nights. Yeah, used it on the Matebook D 14 Ryzen 5 2500U. The only thing that didn't work was the touchscreen. 

  • Archie

    I've tried it and it worked perfectly for me, though I'm still live booting and touchscreen doesn't work also the "connect chromebook to Android device" is greyed out saying its enforced by administrator i dont know if its normal i also don't have a g suite account.
    Anyways its all good with the v75. Thanks randy.

  • Randy

    No problem. If you ever get touchscreen to start working, drop a line on this thread. I personally just cant wait for the new line of amd chromebooks that are supposed to be out in the next 8 or so months. Would love to take a stock Chrome OS image and put it on the Matebook and have access to playstore.

  • pawe3

    @Randy I have couple of questions for You, and Huawei Matebook D14. 

    1. Please tell me does camera and microphone works? On my old computer only camera works, so I can't use Duo for videocalls.

    2. Please tell me does Wifi works stable? On my old computer wifi works quite good, but sometimes it loses signal and I have to reconnect it manually. 

    3. Please tell me does HDMI works? One again, on my old laptop when I connect it to TV nothing happens. No video nor audio.

    I'm thinking of buying Matebook D14. 
    Thanks.

    P.

     

  • Randy

    I recently switched computers and never got a chance to check to see if the camera/mic/HDMI worked on it, I imagine it did though. The Wifi had absolutely no problems for me, everything worked really well with V75.

Please sign in to leave a comment.