Cannot start Crostini, Flatpak buggy apps

Comments

12 comments

  • Forrest Smith

    Hi,

    The lower-end AMD chipset in that machine is aimed at lower-end use cases like education and is not very similar to the hardware where Chrome OS devices officially support Crostini (most of those are newer and Intel-based).

    Those those two reasons together seem to me to be enough to explain the Crostini/Linux issues.

     

    Flatpaks are a different story - the issues you're seeing there are more just because Flatpaks have some bugs unto themselves, and on top of that the UI integration between flatpaks and the Chromium desktop has lots of flaws. Some apps work better than others, but any issues you can't work around may be a while in coming for a fix.

    Any info about use cases that only flatpaks or Linux apps can suffice for would be helpful for us in motivating improvement here - we know there are bugs, but we infrequently get feedback that extends beyond curiosity and experimentation.

  • Jeff Liu

    Thank you for the explanation. I won't be crossing my fingers for Crostini support, but I would like Flatpaks for convenience and integration basically. The apps I plan to install on there other than Authenticator and VLC include: GIMP, JDownloader, qBittorrent, maybe LibreOffice, some games, a text editor, calculator, remote desktop possibly, etc.

    I just tried VirtualBox, but it won't launch... Guess I'll have to use crouton or crosh>shell. But goo.gl is EOL so I can't download crouton right now...

    *Oh wait, got VirtualBox to open after reboot. But 2 extra icons on shelf now... And crouton link back up. Going to test in a bit.

  • Jeff Liu

    OK, VirtualBox was unusable. But after some tinkering around, crouton meets my needs. It's actualy been ~3 years since I last used it, and I sort of swore to never go back when returned to Chrome OS and Crostini became available. But anyways, thanks again @Forrest Smith for the detailed explanation, and I don't expect or need to request for Flatpak to be fixed. CloudReady is a pleasure to use.

    *Though it'd be great if Discord wasn't broken...

    *Flatpak doesn't seem to work on Crouton, and there's basically no information online about that. Unfortunately, it appears the only 2FA Authenticator app is only available via Flatpak, but I guess it's not strictly required.

  • Jeff Liu

    Just found out there's an "Authy" Chrome app, and mastered xiwi windows + switching to xorg, so I'm pretty much set. Also installed Caret and Chrome OS Calculator.

    Only thing left is to fix the Discord website, which Beta 73.2 should help with. Except it seems to be taking longer than usual, what's the hold-up? Any ETA's?

  • Forrest Smith

    Hi Jeff,

     

    I think Discord is working for me in a browser:

    can you provide some additional detail on what steps you're taking that make it fail?

  • Jeff Liu

    It happens right after I sign in. I've tried the web app shortcut I made, Incognito Mode, and even Guest Mode. Always results in "Aw, Snap!"... Maybe it's just this machine or my Discord account? I use 2FA if that helps. Here's a screenshot:

  • Forrest Smith

    can you check whether this happens when you're in guest mode?

  • Jeff Liu

    I've already stated that it does... I'm on 72.4 Stable, let me know if you need more info.

  • Forrest Smith

    my bad - reading too fast.

     

    I'm on v73.1, which is probably why I'm not seeing the problem anymore.

     

    We won't be stabilizing v73, but v74.1 should come out in the coming days for you to try all this on.

  • Jeff Liu

    OK, that's good. Is there an ETA of sorts for Beta 73.2? I notice it's sort of taking a while compared to previous releases...

    *OK, I understand the release model more now. I think I'll still wait for the next Beta (74.2), which should be here by the end of the month (probably weeks earlier). Just hesitant to switch to Dev Channel, I've had a bad experience with it.

  • Jeff Liu

    After updating to 74.2, now Crouton doesn't work... See: https://github.com/dnschneid/crouton/issues/4043

  • Forrest Smith

    Hi Jeff,

     

    I believe this is related to the issue discussed here:

    https://neverware.zendesk.com/hc/en-us/community/posts/360029072334-Lost-Data-upgrading-to-v74

     

    In v74 the MyFiles directory is mounted read/write in Chrome OS, which resulted in Crouton making changes for the new setup.

    CloudReady made the same change in v74.1, but many users found their Downloads folder was missing after that change due to file system issues. In v74.2, we forced the OS back to the pre-74 behavior where MyFiles is read-only and the Downloads folder is the only read-write directory by default. This is probably resulting in the Crouton scripts failing because they expect the new MyFiles setup, not the old one.

    I don't know much about how Crouton works or what changes were made, so I can't offer you a fix or a workaround at the moment. In a later release we will either resolve this conflict or at least find a method that allows users to manually opt-in to the new MyFiles config. Hopefully that will work for you. 

    You can reinstall v72.4 in the mean time if this bug isn't tolerable. 

Please sign in to leave a comment.