New laptop touchpad very very jumpy

Comments

9 comments

  • Forrest Smith

    You may be able to improve this, but it will take some experimentation.

     

    You first need to figure out the pid/vid ID for your device - you can probably find that by running

     

    sudo cat /var/log/messages | grep -i touchpad

     

    You may see a lot of different values there, so poke around and google the terms you find to see if you can confirm the right ID.

     

    Then, you'll want to fool around with editing the files in /etc/gesture/ from the command line in order to add quirks. The easiest thing to try would be to start with adding the pid/vid to one of the sections in /etc/gesture/50-neverware.conf  and see if those pre-defined quirks help.

    0
    Comment actions Permalink
  • Forrest Smith

    We're making some  changes to our KB, so here's a poorly-formatted version of a help article that isn't currently live but may help:

    https://docs.google.com/document/d/e/2PACX-1vSV4dCvvx6aZmOeMWDmrT_1GwtEJlkzRk12E8nkNL5VaesMr55Hk09neKbaHu-gsXQlM6SwKLiRnHPK/pub

    0
    Comment actions Permalink
  • soyef ahmed

    Hi Forrest Smith. I have already implemented the first solution which made my touchpad recognized. The second article you have linked seems very complicated, especially recognizing if I am editing on the right drive. I would like to try that but...
    The article refers to enabling intertouch drivers. My touch pad is not useable for normal mouse operations, BUT is responding smoothly to scrolling and three finger gestures. The scrolling also has "inertia" which suggests it is using intertouch. Because isn't it true that if I was using regular Linux drivers, then the scrolling wouldn't have any "inertia".

    Based on this information, does that point you to any other known issue that could look into? Or would you still recommend following the above article and check if intertouch is enabled?

    BTW, I wouldn't be interested in having Ubuntu grade touch functionality, with jerky scrolling and no gestures. Which is why I am not trying to disable intertouch and enable synaptics. Or am I getting this all wrong?

    0
    Comment actions Permalink
  • Forrest Smith

    I think you're largely interpreting things properly.

    There Are plenty of touchpads that scroll smoothly or mostly-smoothly in other Linux distros, but I agree that Chrome OS and CloudReady are better, and if you're experiencing good scrolling now then you may not want libinput or any more basic setup.

    What happens if you simply disable "tap to click" in settings? Sometimes this fixes jumpy or sluggish touchpads and indicates that sensitivity is the problem.

    0
    Comment actions Permalink
  • soyef ahmed

    Yes Linux do scroll smoothly just no inertia, I guess. Okay, so disabling tap to click doesn't improve anything except that there are no accidental clicks. So with tap to click enabled, the mouse moves 5% of the time and makes 1 or more unwanted click. Disabling it doesn't do the unwanted clicks. Also, the touchpad physical buttons dont work at all. I guess this touchpad is just not compatible with cloud ready.

    0
    Comment actions Permalink
  • Forrest Smith

    Any other edits or recombinations of the quirks you see in any of the files in /etc/gesture/ could help, but if you look through there you'll see that there are many of them so you'll just have to experiment if you want to see what works.

    It is also possible that the touchpad just has a bug/driver issue with recognizing/tracking single fingers. Have you tried v75 or v76? There's an upgraded kernel in those versions compared to v74.4, so updating on our beta channel  is a good thing to try as well.

    0
    Comment actions Permalink
  • soyef ahmed

    Thanks Forrest Smith. That is beyond my comfort zone. For one, I don't know how to explore that folder using command line. But, I probably could find out that from google. But then what edits to make and in which file...sounds too scary for me. I will let you know if I do go down that route and manage to solve anything.

    0
    Comment actions Permalink
  • soyef ahmed

    So far I am still stuck. I've added the pid to the 40-touchpad-cmt.conf file under the elantec entry. So far pointer is still very bad, but better. One thing I have noticed is that, keeping the right click pressed while trying to move the mouse pointer, make the mouse much more responsive. Does the previous observation point to any direction for a solution?

    0
    Comment actions Permalink
  • Forrest Smith

    that suggests more volatility around pressure perhaps? Maybe pressing down a button is stabilizing or steadying the rest of the touchpad. You might want to try adjusting up and down the value of various "pressure" or "sensitivity" values. Any measure or value you see adjusted for other entries beside the elantech one you're using can be copy/pasted to your section for these experiments (though I recommend changing one thing at a time). 

    Generally, adjusting them dramatically up or down (within reason) can help make the change obvious, and then you can refine the value from there.

    0
    Comment actions Permalink

Please sign in to leave a comment.